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Disclaimer

This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of
this Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages,
defines permitted uses of the Software, and determines whether you are an authorized user of the Software. All
information set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer
to the License Agreement for important obligations and applicable limitations and restrictions on your rights.
Trimble does not guarantee that the text is free of technical inaccuracies or typographical errors. Trimble reserves
the right to make changes and additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized
reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve, Fastrak and Orion and are either
registered trademarks or trademarks of Trimble Solutions Corporation in the European Union, the United States,
and/or other countries. More about Trimble Solutions trademarks: http://www.tekla.com/tekla- trademarks.
Trimble is a registered trademark or trademark of Trimble Navigation Limited in the European Union, in the United
States and/or other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other
product and company names mentioned in this Manual are or may be trademarks of their respective owners. By
referring to a thirdparty product or brand, Trimble does not intend to suggest an affiliation with or endorsement
by such third party and disclaims any such affiliation or endorsement, except where otherwise expressly stated.

Portions of this software:
D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
EPM toolkit © 1995-2004 EPM Technology a.s., Oslo, Norway. All rights reserved.
Open CASCADE Technology © 2001-2014 Open CASCADE SA. All rights reserved.
FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.
Teigha © 2003-2014 Open Design Alliance. All rights reserved.
PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.
FlexNet Copyright © 2014 Flexera Software LLC. All Rights Reserved.
This product contains proprietary and confidential technology, information and creative
works owned by Flexera Software LLC and its licensors, if any. Any use, copying, publication, distribution, display,
modification, or transmission of such technology in whole or in part in any form or by any means without the prior
express written permission of Flexera Software LLC is strictly prohibited. Except where expressly provided by
Flexera Software LLC in writing, possession of this technology shall not be construed to confer any license or rights
under any Flexera Software LLC intellectual property rights, whether by estoppel, implication, or
otherwise.

To see all  the third party licenses, go to Tekla Structures, click Help --> About and click the Third party licenses
button.

The elements of the software described in this Manual are protected by several patents and possibly pending patent
applications in the United Stated and/or other countries. For more information go to page
http://www.tekla.com/tekla-patents.
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1 Introduction

1.1 Welcome

 Welcome to the Tekla Structural Designer – Fundamentals training course.

This  comprehensive  two  day  course  will  teach  you  how  to  model,  analyse  and  design  steel  and
concrete buildings effectively using Tekla® Structural Designer. Referencing your existing knowledge,
you will gain a full understanding of how to model with physical objects and undertake gravity and
lateral design. In addition you will grasp the many useful shortcuts that our experts use daily.

1.2 Design Code

This manual has been written based on Eurocode to the UK National Annex. Screenshots throughout
this manual reflect the chosen Eurocode and variations will exist if a different Code of Practice is
selected.

Please refer to Chapter 31 ‘Changing the Design Code’ should you need to design to an alternative
Code of Practice and to understand the implications of switching design code.

1.3 Important Notes Regarding this Documentation

The following conventions have been utilised in the manual;

Step 1. You should undertake these steps so that you learn by “doing” rather than reading.

Tekla Structural Designer from now on will be referred to as “TSD”

A tip might introduce a shortcut, or suggest alternative ways of doing things.

A note draws attention to details that you might easily overlook. It can also
point you to other information in this guide that you might find useful.

You should always read very important notes and warnings, like this one.
They will help you avoid making serious mistakes, or wasting your time.

This symbol indicates advanced or highly technical information that is
usually of interest only to advanced or technically-oriented reader.
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2 The Graphical User Interface

2.1 Introduction

In this section you will understand the Graphical User Interface of TSD and the manipulation of the
screen to enhance your TSD experience.

Step 1. Open the example model file Fundamental Training Completed.tsmd

2.2 The Ribbon

The graphical user interface has been designed so that any aspect of the program can be easily found.

Tabs are created as sub headings with individual commands associated with those sub headings.

2.3 Screen Layout

The initial installation will create a standard program setup similar to that shown below.

Note that individual windows can be resized, repositioned and hidden as per the user’s
requirements.
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Briefly the main areas of the interface are:

1. Modelling View - 3D, plans, elevations, inclined planes al created in a separate tab.

2. Ribbon – command and settings buttons arranged in a number of tasked based tabs.

3. Project Workspace – Detailed information (split into sub tabs) about your model.

4. Project Workspace Sub Tabs – Detailed information arranged in categories.

5. Properties Window – Displays the properties of a selected item which can be viewed or edited.

6. Process Window – Displays the process of analysis and design.

7. Scene Content – On/off settings for displayed objects in the modelling view.

8. Status Information – Current model situation in analysis and design.

9. Modelling View Control – Displays alternative views of your model.

10. Loading Toolbar – Loading control.

11. 3D View Navigation Cube – Displays views by clicking on the corner edges or faces with a rotate
option.
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2.4 Customising the Graphical Interface

2.4.1 Enabling and moving windows

The graphical interface windows can be turned on and off via the buttons on the Windows tab of
the ribbon. Every window or sub tab (not on main ribbon) can be unlocked and clicked and dragged
to various positions.

2.4.2 Side-by-side views

Views can be displayed side-by-side or above/below each other (tiled).

When views are opened right-click the vertical tab and choose New Vertical Tab Group from the
context menu.
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The alternative views (Solver, Results, Review) can also be obtained from
right clicking on View tab.

2.5 Navigating the Interface

2.5.1 The ribbon

2.5.2 The project workspace and properties window

Under the Structure sub tab of the project window, individual items can be selected and properties
displayed.

Note the structure tree can be expanded and individual items selected.
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2.5.3 Generated views

As the model is created, TSD will automatically create views and are listed in the Project Workspace.

To display any view, simply double left click mouse button on it under the Structure tree.

2.5.4 Element select and properties window

By default when no command is activated you are in Select mode.

• Select entities in the visible scene by left clicking on the element – the individual element
properties are displayed in the properties window.
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2.5.5 Clear selection

To clear a selection – press the keyboard Esc key or double right click the mouse button.

2.5.6 Process window

The process window can be activated to appear or permanently docked on the screen. To activate
press this button.

2.5.7 Scene contents

When you have several elements displayed in a modelling view along with their text labels and
rendering styles, the scene can become cluttered and difficult to use.

The Scene Contents allows you to configure what is displayed in the current view.

Each individual modelling view will be controlled by individual Scene Contents
option.
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2.5.8 Model status information

The green ticks or red crosses will show the current status of the model with respects to:

· Analysis Condition

· Concrete / Steel Design Condition

· Modelling System Units

· Model Design Code Adopted

· Coordinate Cursor Position

2.5.9 Modelling view control

The current modelling view can be visualised in several ways.

The default view is the structure view (rendered 3D of the physical model).

· Structural View – for modelling the structure as a physical model.

· Solver View – a simplified view of the underlying analysis model.

· Results View – for viewing analysis results.

· Review Mode – For reviewing and amending certain aspects of the model.

Toggle buttons for changing the view mode can be found at the bottom right of the screen.

When automated wind is applied to the structure a new icon is created for
Wind View.

2.5.10 Loading tool bar

The loading toolbar allow for the visualisation of loadcases and combinations.

2.5.11 Modelling navigation cube

When in a Structure 3D View – move the cursor over the Navigation Cube.

Click on a Corner, Edge or Face to move the view to the one you wish to see.
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2.6 Mouse Control

2.6.1 Zoom, pan and rotate – 3D

When in a structure 3D view you can navigate the screen as follows:

· Scroll mouse wheel to Zoom

· Hold down mouse wheel and move cursor to Pan

· Hold down right mouse button and move cursor to Rotate

o Move cursor vertically to rotate about horizontal axis

o Move cursor horizontally to rotate about a vertical axis

· When an object is selected in the Structure 3D view the model will rotate around that object

2.6.2 Zoom and pan – 2D

When in a 2D view you can navigate the screen as follows:

· Scroll mouse wheel to Zoom

· Also holding the right mouse button allows you to Zoom

· Hold down mouse wheel and move cursor to Pan

2.7 Selection Techniques

Step 1. Open the example model file 1_Selection_Properties_Sets_Start.tsmd

When no command is operational you are automatically in Select mode. This will allow you to select
multiple or individual items and will be highlighted in pink when in a 2D or 3D view.

2.7.1 How do I select an individual entity?

Move the cursor over the required entity in one of the 3D or 2D Views.

· If the entity is the only one at that location it will become highlighted (it will also be the one
listed in the Select Entity tooltip).
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· If several entities exist at the same location they will all be listed in the Select Entity tooltip, with
only the first one being highlighted. If this is not the required entity, use the Tab key  or  the
Up/Down arrow keys or the Ctrl + mouse wheel to scroll through the list.

When the required entity is highlighted, you can either press the Enter key or left click to select it.

The selected entity’s properties are displayed in the Properties window.

2.7.2 How do I add further individual entities to the current selection?

Hold the Ctrl key whilst clicking on each subsequent entity.

2.7.3 How do I deselect a single entity from the current selection?

Hold the Ctrl key whilst clicking on the entity you want to de-select.

2.7.4 How do I select multiple entities?

There are three methods available which will be discussed below.

(1) If you only want to select those entities which are totally encompassed by the box, then:

· Move the cursor to the left corner of an imaginary box which will encompass the entities that
you want to select.

· Click and hold the left mouse button.

· Drag to the opposite right corner (you  will  see  a  purple  rectangle  box  on  the  screen  which
follows your mouse movements and helps you to check the area you are selecting).

· Release the mouse button.
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This will only create a selection for those entities encompassed by the box.

Hold the Ctrl key to add to an existing selection.
If you drag a box to encompass a stack of a column the entire column will be
included in the selection.

(2) If  you want  to  select  those entities  which are totally encompassed by the box, and which it
crosses, then:

· Move the cursor to the right corner of an imaginary box which will encompass the entities that
you want to select.

· Click and hold the left mouse button.

· Drag to the opposite lower left corner creating a green rectangle box.

· Release the mouse button.

This will only create a selection for those entities encompassed by the box and which it crosses.
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(3) If you only want to select those entities which cross a line,

· Move the cursor to the start of an imaginary line which will  encompass the entities that you
want to select.

· Hold the Shift key and click and hold the left mouse button.

· Release the mouse button then the Shift key.

2.8 How Do I Deselect All Entities?

Double right click mouse button or press the Esc key will deselect all currently selected entities.

2.9 Selection Entities via Structure Tree

Only individual entities or groups of similar entities can be selected from the Structure tree, (it is
not possible to select multiple members in this way).

· Expand the Members branch of the Structure tree and then the appropriate sub-branches until
the member references are displayed.

· Click either a single entity from the list (to select just this entity) or the folder (to select all).
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Right click the required member’s reference or folder and then pick Select in
visible views from the context menu to highlight in the view.

2.10 Properties Window

When a new entity is created, it adopts the properties that are displayed in the Properties window
at that particular time. You should therefore ensure the properties are correct before you place the
entity.

When an existing entity is selected its properties are displayed in the Properties window where they
can be edited.

2.10.1 How do I edit the properties of a single entity?

Select an entity and change the properties as required using the Properties window.

Individual properties can also be edited via the Properties dialog, by right
clicking an entity in the View and choose Edit from the context menu or by
double left clicking on an entity in the View.
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2.10.2 How do I edit the properties of multiple entities?

· If multiple entities of different types are selected, then properties information is displayed
separately for each type.

· A dropdown menu at the top of the Properties window is used for moving between types.

The Properties window will show a blank where an item (Reference format,
Alignment, Offset, Report etc.) is not identical for all the selected entities.

o If you change a blanked item, the new setting are applied to all the
selected entities.

o If you leave a blank item blank, then the current diverse settings for
the selected entities are maintained.
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Step 1. Select the roof eaves beams highlighted in below (using Ctrl key for multiple selections).
Review the Properties window to confirm 4 entities are selected.

Step 2. Change the characteristic to a Brace (1), untick Autodesign (2) and assign the Section as a
CHS 88.9x5.0 (3) section. The View is updated to reflect the changes.

Step 3. Undo 3 times the previous changes.

Pressing Undo once undoes the last property change i.e. Section. Thus you
will need to press undo three times to revert back to the characteristic Beam!
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2.11 Property Sets

In a typical model you may want to apply the same properties to similar members at a number of
different locations. To do this efficiently, once properties have been set up for a member you can
save them away to a named Property Set for subsequent recall.

2.11.1 How do I save properties to a named property set?

Property Sets can be created before you place an entity in the model or can be created from an
existing entity that is already in the model.

How do I create a property set prior to creating an entity in the model?

Properties can only be saved to a Property Set from the Properties window when there are no items
selected - this ensures that unique entries exist for each of the properties in the set.

Step 1. Click on the Steel Beam command on the Model tab.
Step 2. The drop list at the top of the Properties window should read ‘<unsaved set>’.
Step 3. Specify the properties as required, then click the Save... button.

Step 4. Enter a name called Trimming Beam for the saved set.

How do I create a property set based on an existing entity in the model?

Properties for an existing entity in the model can be saved as a property set by.

Step 1. Right clicking on an entity (say an edge beam) you wish to
save the properties for.

Step 2. Select Create property set… from the context menu.
Step 3. Enter a unique property set name called Edge Beam.

2.11.2 How do I recall a previously saved property set?

To create a new entity

Provided you have previously saved a property set, you can recall it again later from the Properties
window - but only when it is applicable to the current command.

For example, assume different steel beam properties have previously been assigned to the main,
secondary and edge beams in a structure, each being saved to a set for re-use. You subsequently
want to re-use the edge beam properties.
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To recall the edge beam property set:

Step 1. Click the Steel Beam command on the Model tab
Step 2. Click the drop list at the top of the Properties window - only the previously saved steel

beam property sets are displayed.
Step 3. Choose the saved Edge Beams property set.

Properties previously defined and applicable to steel beams only are
displayed in the Properties window.

To apply to an existing entity

Step 1. Select a few edge beams in the model

If multiple entities of different types are selected, then property information
is displayed separately for each type. A dropdown menu at the top of the
Properties window is used for moving between types.

Step 2. Select the type to work with.

Step 3. Click Apply…

Step 4. Select on Edge Beam from the list of the property set and click OK to apply the change.
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2.11.3 How do I manage property sets?

Property sets can be managed from the Home tab using the Manage Property Sets command.

The different property set types such as line elements are listed.
Click the + icon to expand the list to show the sub-items.

To import or export saved property set, select the required property set in the list and click the
Export or Import button. Give a filename and save it.

To delete a saved property set, ensure the property set is ticked and click the Delete button.
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3 Model Validation

3.1 Introduction

The  purpose  of  Validation  is  to  trap  errors  that  will  cause  the  solver  to  fail  before  the  model  is
submitted for analysis.

3.2 How Do I Run Model Validation?

Validation is automatically performed as part of an analysis or design. You can however, run a manual
validation at any time from either the Model or Load tab with the Validate command.

The actual validation checks that are performed can be set within Model Settings accessible from
the Home tab.

Step 1. Open the example model file 1_Model_Validation_Start.tsmd.
Step 2. Review Model Settings from the Home tab to see the validation checks that are included

in a validation check.

Step 3. Click Validate command on either the Model or Load tab.

The validation checks are performed on the model and if any issues exist these
are displayed as Errors or Warning messages within the Status tab in the
Project Workspace.

3.3 What are Validation Errors and Warnings?

The results of model validation are broken down into two distinct types; Errors and Warnings.

· Error messages must be rectified. You are unable to complete an analysis or design without
resolving.

· Warning messages are for your information and usually relate to a design assumption. Review
the message and take action if required or ignore if you are happy with the assumption.
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3.4 How do I Locate Validation Errors?

3.4.1 Working with the status tab in the project workspace

The Status is used to review the validation status for the model and analysis. The analysis model
validation is performed automatically as part of the analysis process so we will not look at analysis
validation in this session.

Step 1. Go to Status tab (1) in the Project Workspace and expand the Validation > Model branch
by clicking on the “+” icon to display the model validation errors.

Step 2. All model validation errors are listed under the Model sub-branch.
Step 3. Ensure the Structure 3D View is active (2).
Step 4. Double left click the error or warning message you wish to investigate (3).

Step 5. Provided the item is visible in the active view it will be highlighted ready for investigation.
Step 6. Use Scene Content to make the view clearer if necessary.

Investigate the highlighted item in the View to determine the issue in
conjunction with the validation message.

3.5 Common Validation Errors

3.5.1 “Panel is not surrounded by load carrying members”

RI (Roof Item)

Step 1. Locate the reported roof item (RI 2) by double clicking on it.
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Step 2. Review the elements supporting this roof panel.
The panel must be bounded by beam members.

Step 3. To resolve, change the supporting element from a Brace to a Beam element.
Step 4. Validate again to see if the issue has been resolved.

SI (Slab Item)

Step 1. Open plan view of St.1 (2) 2D
Step 2. Locate the slab item (SI 14) by double clicking on it in the error message.
Step 3. Review the elements supporting this slab panel.

The panel must be bounded by members.
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Step 4. To resolve, select the slab panel. Hover over the top right corner of the panel and using the
Select Entity tooltip select the Node on SI 14.

Step 5. Move the cursor over the beam and column intersection and use the Select Entity tooltip
to highlight the required location - use tab to pick on “Inters” (intersection point).

Step 6. Hit Enter or left mouse click move the panel node to the new location.
Step 7. Repeat Step 3-5 on the other node of the panel to align the panel edge with the beam.
Step 8. Validate again to see if the issue has been resolved.

Both panels have been resolved because the 1st and 2nd levels are duplicate
levels. Change something on one level and the change also occurs on the
other level.
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3.5.2 “Members collision”

Step 1. Double click on the reported member under ‘Member Collision’ error list to locate it.

Note there are two entities that collide with each other.

Step 2. Select the entity that is not required, in this case the Brace and Delete.
Step 3. Validate again to see if the issue has been resolved.

3.5.3 “Member Intersection”

Step 1. Double click on the member under ‘Member Intersection’ error list to locate it in the View.
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Step 2. Use the Scene Content to turn off Slab Items, Trusses, Wind Panels & Roof Panels.

Step 3. Also turn off Geometry of the Members to change the solid shape display to single line
display.

Step 4. Zoom in to where the entities meet. Note that one entity over sails the other. One entity
should support the other.

Step 5. Select the node at the end of the entity and move the node to snap on the intersection
point of the entities - use tab to pick on “Elm Inters”
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Step 6. Validate again to see if the issue has been resolved.

Both level member collisions have been resolved because the 1st and 2nd
levels are duplicate levels, i.e. change something on one level and the change
also occurs on the other level.

Step 7. In Scene Content check the options to display Members Geometry, Slabs Items and the
Trusses again.

3.5.4 “Slab Overlap”

Step 1. Double click on ‘Slab Overlap’ to highlight the reported slabs in the View.

You will need to have slabs on in Scene Content to be able to identify them in
the active view.

Step 2. Switch to the plan view of St.1 (2) 2D and review the slab boundary edges where the two
slabs intersect.
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Step 3. Select the Node on SI 2.

Step 4. Move it to the intersection point of the two beam entities using the Pick Point - “Inters”
tooltip.

Step 5. Validate again to see if the issue has been resolved



3 Model Validation 41 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

3.6 Right Click Context Menu

Right  clicking  the  mouse  either  on  a  selected  item  or  free  space  of  the  screen  will  bring  up  an
additional menu at the cursor position.

3.7 Command Activation

When any command is activated a yellow band will be seen across the top of the active view.

Press the Esc key or double right mouse click to exit a command.

Use the Scene Contents to simplify the view when it becomes too cluttered.
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4 Tekla Structural Designer Help

To active the help menu press F1 on the keyboard

You can also click on the button at top right corner of the
program screen.
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5 Multi Material Modelling 2D

5.1 Introduction

· Pre model settings

· Construction levels and gridlines

· Placing structural elements

· Construction lines and free form truss

· Element releases

· 2D loading – loadcases / combinations

· Validation, analysis and viewing graphical results

· Tabulated results

5.2 Model and Global Settings

5.2.1 Settings

Before creating a new model, the Settings command on the Home tab should be reviewed to ensure
the required options are selected.  All new models that are created take these settings to generate
their own model settings for the new file, and includes options for default design codes, analysis and
design options, default section sizes, label and colour settings and detail drawing options.

Step 1. Launch Tekla Structural Designer 2016.
Step 2. Click on the Settings command on the Home tab.

5.2.2 Settings Sets

When first opening TSD, you will be prompted to select the country to import the settings for.  This
specifies the default active Settings Set, which defines all of the default options in the Settings
window.

The selected Settings Set can be changed by selecting Settings Sets on the left hand side of the
Settings window, then by clicking the Import button.  You can import multiple different Settings Sets
for different regions, create new, customised sets to suit specific clients or project types, and edit
existing sets.  Settings Sets are edited by selecting the required set in the drop list, and then making
the required changes on the other pages of the Settings window.  The Settings Set that is made Active
is the one that will be used to create any subsequent new models.  The active settings set can also
be imported into existing models.

For more information on this topic, please refer to the Help system.
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Step 3. Ensure you have “UK Settings” set selected and make it Active.

5.2.3 Design Codes

As some regions have multiple different design codes, or with the possibility of you designing a
structure that will be located in a different country, you may need to change the design code to be
used.  This is done by selecting Design Codes on the left hand side of the Settings window.  You can
then select the Head Code option to make an overall change to all Action and Resistance Codes to
be used, and then adjust the specific design codes and years for specific areas if required.

Currently Design is only available for British Standards, Indian Codes,
Eurocodes, ACI/AISC codes.

Step 4. Ensure “United Kingdom (Eurocode)” head code is selected.
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5.2.4 Section Defaults

If there are certain section sizes that you use regularly, or a section that will be commonly used in a
project, you can also specify default section sizes for concrete beams and columns by selecting
Section Defaults on the left hand side of the Settings window.

Step 5. Accept the default section sizes.

5.2.5 Analysis Options

As well as options for the various different analyses, the key settings for concrete structures are the
concrete Modification Factors, found under Analysis Options > Modification Factors > Concrete.
There are factors for the Building Analysis (i.e. the 1st Order Linear Analysis), the Grillage Chase-
down and the FE Chase-down, and allow you to make adjustments to the stiffness of the various
element types, for cracked and uncracked sections, to allow for long term effects.  These adjustments
will naturally have an impact on the analysis results, so it is important to set them as required.

Step 6. Review the various Modification Factors.
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5.2.6 Concrete Design Options

All automated concrete designs are completed based on the concrete Design Options.  There are
settings available for the designs of beams, columns, walls and slabs, controlling minimum and
maximum bar sizes, spacing, links, reinforcement arrangements and detailing options, amongst
others.

Step 7. Review the numerous concrete Design Options.

5.2.7 Drawings

A wide variety of detail drawing settings are also available within the Settings window.  These can
also be set up in anticipation of creating all new models to control content, layers, colours and more,
but these settings will be discussed in more detail in a later section of this course.

Step 8. Review the Drawing settings, then click OK to confirm all setting changes.
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5.3 Materials

As well as the variety of analysis, design and general settings, the Materials command on the Home
tab should also be reviewed to ensure the required options are selected.  All new models that are
created also take these material settings to generate their own model settings for the new file, and
includes options for default concrete and reinforcement grades and rebar sizes.

Step 1. Click the Materials command on the Home tab.

5.3.1 Concrete Grades

The Head Code setting under the Material options allows you to choose concrete grades from a
variety of different regions.  You can then set the default concrete grade to be used, and add
additional grades if the one you want to use is unavailable.

Step 2. Review the Material settings.

5.3.2 Reinforcement

As with the Material options, the Head Code setting under the Reinforcement options allows you to
choose steel grades from a variety of different regions.  You can then set the default rebar steel grade
to be used, and select which bar sizes are available for the design of your structure.  Additional bar
sizes can also be assed to the list for selection.

Step 3. Review the Reinforcement settings, then click Close to confirm them.
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5.4 Templates

As well as being able to use the Settings and Materials options to generate the Model Settings for a
new project, another option is to use Templates.  A Template can be used to specify all of the same
settings as detailed above, but they can also include modelling, such as grid lines and elements.  This
could useful for when you have multiple models to create that all use the same gridlines, or perhaps
have a common core area.

New templates are created by first creating a new file by clicking the New command on the Home
tab.  Once this blank project is created, you can then edit the Model Settings as required, as well as
insert any particular grids, section sizes and elements that you want in the template.  Once this is
done, simply go to File  >  Save  As,  choose  a  name  and  location  of  where  you  want  to  save  the
template, and set the Save as Type file format to *.tsmdt.

Once a template file has been created and saved, you can then use the drop down arrow under the
New command on the Home tab and choose your template.  This will actually open the template
file, so you then just need to save this as a *.tsmd file so that you can continue to model the structure
and leave the template file as it is.

5.5 Starting a New Project and the Project Wiki

Step 1. Click on the New command on the Home tab to start a new project.

To enter details about the project into TSD click the Project Wiki command on the Home tab.
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Within the Project Wiki the Metrics of the model can be displayed – number
count of analysis and physical elements

5.5.1 Model Settings

When a new model is created the settings and parameters of that open model is contained in the
Model Settings.

The Model Settings are specific to each model and are based on the previously defined Settings
and Materials options, as detailed previously.  This means when they’re edited, they will only affect
the currently open model.  If required, you can load your currently active global settings into an
existing model by clicking the Load button in the Model Settings window.  This may also be
necessary in other windows, such as the Analysis or Design Options windows.

5.6 Modelling – Establishing the Structural Geometry

5.6.1 Construction Levels

The methodology we are going to adopt to create this structure is to create an individual frame and
copy and repeat to produce the building. First let’s establish the initial levels of the building.

Step 1. Select on the Construction Levels command from the Model tab.
Step 2. Click the Insert Above button to generate the levels as seen below.
Step 3. Enter the details as shown.
Step 4. Press OK when finished.
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§ TSD will automatically generate levels where appropriate.
§ The Construction Levels dialogue requires the information to be entered

sequentially.

5.6.2 Grid and Construction Lines

To place any structural element in the modelling environment an intersection position has to be
created.

An intersection point can be created using Grid Lines or Construction Lines and the crossing of two
lines will allow a structural element to be placed at that point.

§ Grid Lines are created on a horizontal plane.
§ Construction lines are created on sloped, vertical and inclined planes.

We will used a wizard to create a rectangular grid system in the model.

Step 1. Click on the drop list of the Grid Line command and select Rectangular Wizard.

Step 2. The first page of the wizard allows you to enter a name for the grid and set which levels it
will appear (this can be edited after creation) press Next.

Step 3. Set the grid origin position at the defaulted values of X=0, Y=0 and press Next.
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Step 4. The next dialogue will ask the directions of lines to be generated – accept the defaults (All
Lines) and control the style of the lines - press Next.

Step 5. Generating lines in the X direction enter Count=5 & Length=6m and press Next.

§ Labelling of the gridlines can be selected by letters or numbers.
§ If an irregular pattern of grids is required – use a “,” as a separator or “*”

for multiples.

Step 6. Generating lines in the Y direction enter Count=2 & Length=12m and press Next.

§ As information of the grid is being placed into the wizard the background
screen (base level) will adjust accordingly.

§ Pan and Zoom will be functioning as mentioned in the mouse controls
earlier.
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Step 7. Grid Rotate – accept default values of 0 degree.
Step 8. Axis Angle (rectangular grid skewed) accept default values of 90 degrees relative to X axis

and press Finish.

The following will be displayed in a 2D and 3D view:

§ The view above is tiled – see customising the graphical interface.
§ Currently the 3D view only shows the Grid System at a single level.

5.6.3 Graphically displaying Grids

Currently TSD is showing the Architectural Grids at the lowest level in the 3D view.

To make the gridlines visible on the level you wish.

Step 1. Select the Structure 3D view.
Step 2. Turn on Grids and Construction Lines display from the Scene Content.
Step 3. Expand the Levels branch under the Structure in the Project Workspace - Structure tab.
Step 4. Highlight an individual level.
Step 5. In the Properties window, tick the Show grids in 3D view option.
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The same process can be adopted for the plan 2D views.

Vertical lines can be displayed to make intersection viewing easier between levels.

Step 6. Open the Scene Content.
Step 7. Next to Grids and Construction Lines, click on the ‘arrow head’ to display more options.
Step 8. Select Vertical Lines and press OK to display.

5.6.4 Adding additional gridlines

In this section we will add two additional gridlines to the main grid.

Step 1. Go to St. Base (Base) 2D view and select the Model tab.
Step 2. Pick the drop list option under Rectangular Wizard / Grid Line command.
Step 3. Pick the option Parallel (quick).

Launching this operation will place a yellow information bar across the active window.

Step 4. Select on gridline 2 to act as a reference position (position to measure from).
Step 5. Move the cursor vertically to specify an offset direction.

You can click any position graphically to specify a parallel gridline on screen.

Step 6. Specify an actual distance by pressing the F2 key and enter a value of 6m.
Step 7. Place parallel gridlines above and below the reference line.
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Step 8. Press Esc or double right mouse click to exit the operation.

5.7 Selecting Elements for Editing

5.7.1 Gridline Properties

The new horizontal lines have grid label out of sequence with the rest of the grid system.

To change the properties of any gridlines the element need to be selected and the grid label re-
referenced.

Step 1. Select on gridline 4 to be changed by left clicking on the item (notice the pink selection
colour).

Look at the Properties window and the editing options for the selected gridline are displayed.

Step 2. Go to User name and enter the new name as 1a.
Step 3. Press Enter to apply the change.
Step 4. Press Esc to exit the selection process.
Step 5. Repeat the same procedure to rename gridline 5 to 2a.
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5.8 Dimensioning and Measuring Tools

5.8.1 Dimensions

A dimension can be added to the scene in either the 2D or 3D view.

Step 1. Go to Base 2D view.
Step 2. Click on the Dimension command and follow the instructions given in the operation yellow

bar – create some dimensions.
Step 3. Press Esc to exit the operation.

5.8.2 Measuring tool

Under the Home tab there are options for Measure and Measure Angle command – follow the
instructions given in yellow information bar.

5.9 Deleting Elements

5.9.1 Delete command

There are several methods to delete an established object in the model. To delete any object
(dimension), from the Quick Access toolbar click the Delete button.
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The quick access toolbar is an access point for popular commands, use the
drop down arrow to modify.

Step 1. Follow the instructions given in the yellow command bar – delete a dimension.

Options for Delete:

· Single Left Click on an individual element.

· Left Click and Hold - Create a blue box (upper left to lower right) and delete any element
totally contained within the box.

· Left Click and Hold – Create a green box (upper right to lower left) and delete.

· When multiple elements are selected for deletion a filter box will appear for confirmation.

5.9.2 Prior selecting before delete

In selection mode, elements can be pre-selected and then the command of delete activated.

Step 1. Make a multiple selection of different elements.
Step 2. To delete the selection press the Delete button on the keyboard or click on the Delete icon

in the quick access toolbar.
Step 3. Delete all dimensions.
Step 4. Press Esc to exit the operation.
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6 Creating Structural Elements

6.1 Concrete Columns

We wish to create five concrete columns on the intersections of gridline B.

The outer columns extending to eaves level and the internal columns to the first floor level.

Step 1. Activate the 2D Base view.
Step 2. Click on the Concrete Column command on the Model tab.

Step 3. In the Properties window under Section pick the option New/Edit.
Step 4. Edit the rectangular section to have a depth of 600mm.

Step 5. Then press the OK button to accept the new section size.

Take note of all the different concrete column shapes that can be designed in TSD.

Step 6. In a 2D Base view create a box around gridline 2 – take note of the cross hairs at the
intersection points indicating a column is going to be created.
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Step 7. Press Esc to exit the operation.

In the 2D base view take note of the concrete column alignment which is an option
in the property grid – we will be changing these later.

6.1.1 Editing column properties – levels

Changing the column heights of the internal columns.

Step 1. In either the 2D or 3D view select the internal columns.
Step 2. In the Properties window adjust the Top level of these columns to St. 1(First Floor).
Step 3. Press Esc to exit the selection process.

6.1.2 Editing column properties – alignment

Ensure that the outer concrete columns Alignment is set to Centre / Centre.

Step 1. Select the two outer columns.
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Step 2. In the Properties window, under Alignment set Major snap level and Minor snap level to
be both Centre.

6.1.3 Changing column characteristics – central steel column

Step 1. In either the 2D or 3D view, select the central column.
Step 2. In the Properties window and change the Material Type to Steel.
Step 3. Set the Construction to Non-composite column.
Step 4. Tick the Autodesign option.

Step 5. Press Esc to exit the operation.

6.1.4 Changing column properties using property sets

Now that we have established the properties of the central column, we can create a Property Set
and use those properties to apply to other elements.

Step 1. Either in a 2D or 3D view, right click over the central steel column (highlights green).
Step 2. Select Create property set…” from the context menu.
Step 3. Enter the name Steel Column 1 for the property set.
Step 4. Press OK.

Step 5. Select the remaining two internal columns and check the property grid that you have 2
columns selected.
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Step 6. With the columns selected press the Apply button.
Step 7. The pop up screen will allow you to pick the Property Set you want to apply – select on

Steel Column 1 and press OK.

Step 8. Press Esc to exit the selection operation.

The  Internal  columns  will  have  the  property  set  now  of  steel,  created  from  an  element  already
established in the model.

6.1.5 Managing property sets

All created property sets can be deleted or imported/exported to other projects.

Step 9. On the Home tab, select Manage Property Sets command.
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6.2 Obtaining Model Views

6.2.1 Obtaining a 2D frame / elevation view

Step 1. Go to Structure 3D view and in the Model tab click the Frame command.
Step 2. Move the cursor over Grid Line B and left click to execute (blue boundary box will appear

to show the elevation you are creating).

Step 3. In the Project Workspace – Structure tab, under Structure tree expand the Frames branch.
Step 4. Double click FRM B to display its 2D view.

6.2.2 Obtaining a plan / level view

Information entered into the Construction Level dialogue will automatically generate a 2D plan level
which can be extracted as a working view.

Step 1. In the Project Workspace – Structure tab, under Structure tree expand the Levels branch.
Step 2. Double click the level name St. 1(First Floor) to open the 2D plan view.



6 Creating Structural Elements 64 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

Zooming into the plan view will show the definition of the structural elements
placed into the project

6.3 Concrete Beams

In this section, we will place the following concrete and steel beams at the first floor level along
gridline B.

· Concrete Beam size – Breath 400mm x Depth 900mm
· Steel Beam – Auto Design

Step 1. Obtain either a 2D elevation\frame view of gridline B or a 2D plan view of the First Floor.
Step 2. On the Model tab, click the Concrete Beam command.
Step 3. In the Properties window, create a new section size of 400mm breath and 900mm depth.
Step 4. Press OK.

6.3.1 Creating a property set from a new element

When a new element is being placed into the model the properties can be saved.

Step 1. Press the Save button in the Properties window.
Step 2. Enter the Property Set name to be Concrete Beam 1.
Step 3. Press OK.
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This property set can be applied to element in the structure by pressing the Apply
button.

Step 4. Either in the 2D Plan view or Frame view, place 2 concrete beams in the outer bays.

If in a frame view use the Intersection option in the context menu (select by the
arrow keys or tab key to pick the point required).

6.4 Steel Beams

Using the same methodology, we will place first floor steel beams in the remaining proportion of the
frame.

Step 1. Obtain either a 2D Plan or Frame view of gridline B.
Step 2. On the Model tab, click the Steel Beam command.
Step 3. Tick the AutoDesign option in the Properties window.
Step 4. Place the steel beams in the remaining area of the floor.
Step 5. Press Esc to exit the operation.
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7 Construction Lines and Free Form Truss

In this section, we will be creating a faceted freeform truss comprised of steel members. We will be
using construction lines to create the form of steel truss.

· Gridlines are placed on the horizontal level.

· Construction lines placed on sloped or vertical views.

Steel Sections to be placed in the model – these can be saved as property sets.

7.1 Construction Lines

We will be using construction lines to create the faceted curve of the truss.

Step 1. Select the Frame View of gridline B.
Step 2. On the Model tab, click the Construction Line command.
Step 3. From the drop list option, pick Parallel (Quick).
Step 4. On the frame view of gridline B, click the gridline for the base level to act as a reference

line then move the mouse cursor down to indicate the offset direction.
Step 5. Press the keyboard F2 button to access the distance entry box.
Step 6. Type an offset distance of 26m and press the Enter key to create that line.
Step 7. Press Esc to exit the operation.

Now we need to create a vertical line to intersect this line.

Step 8. From the same drop list option, choose Construction Line.
Step 9. Click on the bottom of the existing middle vertical line to start.
Step 10. Move the cursor vertically down to pass the new created horizontal line.
Step 11. Click to create a new vertical line.
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Creating an arc to describe the top of the truss.

Step 12. On the same drop list option, pick Arc.

Step 13. To create the arc – click on the lower intersection just created.
Step 14. Then click on the Right Hand Eaves position to define the beginning of the radius.
Step 15. Finally click on the Left Hand Eaves position to define the end of the radius.
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· When several objects are displayed in a view – Zoom in to pick on the correct
intersection point.

· If a mistake has been made during the process right mouse click to go back a
step.

To create a series of vertical lines to define the truss bays, we use the rectangular wizard in the same
frame view.

Step 1. On the same drop list option, pick Rectangular Wizard.

Step 2. When picking the Origin position pick the bottom left of truss bottom level.

Step 3. Generate Y Direction Lines Only to construct vertical lines at a distance of 4m.

Step 4. Press Next to continue.



7 Construction Lines and Free Form Truss 70 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

Step 5. In the X direction extents, generate 11 Count of vertical lines at 2m intervals.

Step 6. Press Next.
Step 7. Accept the defaults for Rotation Angle and Axis Angle.
Step 8. Press Finish to create the vertical lines.

The arrangement of the construction lines to define the truss is now complete.

7.2 Steel Truss

7.2.1 Free Form truss properties

Step 1. On the Model tab, click Steel Truss command.
Step 2. From the drop list option, pick Free Form.
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Step 3. In the Properties window, establish the following sections and save individual Property
Set:

· Characteristics Truss member top
· Grade S355
· Section 150x150x8.0
· Design section order SHS Hollow
· Property set name Truss Top Boom

· Characteristics Truss member bottom
· Grade S355
· Section 150x150x8.0
· Design section order SHS Hollow
· Property set name Truss Bottom Boom
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· Characteristics Truss Internal
· Grade S355
· Section 100x100x4.0
· Design section order SHS Hollow
· Property set name Truss Internal

7.2.2 Modelling booms

Place individual faceted members to create the top boom of the truss.

Step 1. Ensure that the saved property set Truss Top Boom is selected from Properties window
drop list.

Step 2. Click on individual intersections to pick point to insert truss element.
Step 3. Repeat the placing of the truss elements until the centreline (at gridline 2).

Step 4. Create a single truss element to the centreline (at gridline 2) for the bottom boom –
remember to change the Property Set to Truss Bottom Boom.
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7.2.3 Modelling internals

Step 5. Set to use the Truss Internal property set in the Properties window grid and place the
following truss elements up to gridline 2.

7.2.4 Member Releases

Step 1. Select all the elements of the top boom and ensure the releases of both ends are Fully
Fixed.

Step 2. Now select the first (individual) member that is connected to the column and set releases
at Fixity end 1 to Pin.

End 1 – start of the member / End 2 – end of the member.
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Use Scene Contents and turn on the truss element direction - tick Trusses >
Direction.

Step 3. Repeat the same process for the bottom boom to set it fixed at its end along gridline 2
and pinned at the end at the column.

To view the releases on the model, use Scene Contents – ticked 1D Element >
Releases.
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8 Mirror Command

We will use the Mirror command to establish the remaining elements of the truss.

Step 1. In the frame view of gridline B, select all elements of the truss.

The Select operation will give you the option to pick individual members of the
truss or the whole truss.

Step 2. Under the Edit tab, pick Mirror command.

Step 3. Ensure that the Mirror Mode is in the “XZPlane” and you pick the reference point at
gridline B bottom boom level.

Step 4. Place in the final Internal truss member and Save the Project.
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9 Loading

The following loading will be placed on the frame considering centres at 6 meters (unfactored).

· Frame Self Weight  – Automatically Calculated

· Dead (line load on first floor beams) considering 200 thick slab – 0.2 x 25 x 6  = 30 kN/m

· Floor Imposed (line load on first floor beams) 3.5 kN/m2             – 3.5 x 6          = 21 kN/m

· Roof Imposed (point loads on top boom of truss) 0.6 kN/m2       – 0.6 x 6 x 2    = 7.2 kN

9.1 Loadcases

Step 1. Obtain a Frame/Elevation view of the structure.
Step 2. On the Load tab, click the Loadcases command.

Step 3. Turn off the option of Calculate Automatically for the “Slab self weight” loadcase.

Step 4. Delete the “Services” loadcase by highlighting the line and pressing the Delete button.

Step 5. Change the name and type of the Imposed to Roof Imposed.
Step 6. Add a “Floor Imposed” loadcase
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Step 7. Press OK to exit this dialogue

In this dialogue, unlimited number of loadcases can be created and automatically
merged into combinations for a specific design head code.

9.2 Applying Member Loads

All loading is applied graphically by selecting the individual loadcase and then applying the load.

Step 1. Select the Slab self weight loadcase from the drop list option.

Step 2. Under the Load tab, click the Full UDL command.

Step 3. Enter the load value 30 kN/m in the Properties window and set the direction to Global Z.
Step 4. Graphically left click on the beam in the frame view to apply the load.

Step 5. Use the Scene Contents to display the loading text on the screen.

Step 6. Set to Floor Imposed loadcase and apply Full UDL of 21 kN/m on the same beams.
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9.3 Applying Nodal Load

On the top boom of the truss, we will place individual nodal loads at the intersection of internals.

Step 1. Set to Dead loadcase.
Step 2. Under the Load tab, pick the Nodal Load command.

Step 3. Apply vertical load of 3 kN / 6 kN at the intersections on the top boom.

Step 4. Set to Roof Imposed loadcase.
Step 5. Apply vertical load of 3.6 kN / 7.2 kN at the same intersections on the top boom.
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10 Load Combinations

Tekla Structural Designer has an inbuilt wizard which will produce code based combinations.

Step 1. Under the Load tab, click the Combination command.
Step 2. Click on the Generate… button in the combination dialogue.
Step 3. Pick the option of Table A1.2(B) – Eq 6.10a&b.
Step 4. Press Finish and OK to exit the combinations dialogue.

This will generate two gravity combinations to the model – they can be inspected and edited by
selecting the individual combination in the list on the left.
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11 Validation

Before running any analysis or design it is recommended to validate the model – TSD will check for
any modelling errors that can cause problems with the model.

Step 1. Click the Validate command on either Model or Load tab.
Step 2. Go to the Project Workspace and click on Status tab to check if there is any issue reported

on the model.

Validation has the following status:
§  - Status OK, no issues found
§  - Status unknown / Not yet checked
§  - FYI (For your information) issues to consider but will not prevent

analysis/design
§  - Errors that must be resolved

If an error existed it would be highlighted in the Status / Project Window and can
be double clicked to be highlighted.
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12 Analysis and Viewing Graphical Results

Even after performing a validation check there still maybe issues with your model in analysis such
as large deflections, degrees of freedom, buckling etc.

12.1 Running 1st Order Linear Analysis

Step 1. Select the Analyse tab and click the Show Process button (at left bottom corner of the
screen).

Step 2. In the Analysis tab, click the 1st Order Linear command.

Step 3. Select all loadcases and combination to be analysed.

· Take note of the Process window which will reveal any potential problems
with the model.

· When the analysis is complete the Project Workspace will switch to the Status
tab – any analysis problems will be displayed.
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12.2 Loading Summary Table

Do the applied loads equal the reactions? TSD automatically does this mathematical check for you.

The Loading tab within the Project Workspace is used to organise the loadcases and combinations
into a hierarchical structure. It also provides a summary of each loadcase that can be used to cross
check against the load applied.

Step 1. Select the Loading tab in the Project Workspace.
Step 2. Highlight a loadcase or combination to examine the Total Load on Structure vs Total

Reactions.

If there is discrepancy between total load on structure and total reaction, you need
to investigate and check on the model for any incorrect input or modelling mistake.

12.3 View Analysis Results

Results for the model are available both graphically and numerically.

Step 1. In the current view, select the Analysis Results View found at the bottom of the screen.
Activating this view will open the ribbon tab for Results.



12 Analysis and Viewing Graphical Results 87 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

§ 1D Results represents single wire elements (such as beams and columns), while
2D Results represents area elements which are finite element results (such for
slabs and walls).

§ Multiple results can be displayed on the screen at any one time, example
support reactions along with axial forces and deflections.

§ Please remember to pick the appropriate loadcase or combination.

Select a loadcase or combination of the result you would like to view using the toggle buttons and
drop down list.

Create the following graphical results display: Z deflections, axial, vertical support reactions for the
combination 1 STR1-1.35G+1.5Q+1.5RQ.

Step 2. Under Result Type - select 1st Order Linear.
Step 3. Under Deflections – click on Z.
Step 4. Under 1D Results – click on Axial Force.
Step 5. Under Support Reactions – click on Fz.

Step 6. Set the combination to 1 STR1-1.35G+1.5Q+1.5RQ from the drop down list option.
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The following results is displayed:

Step 7. Toggle the 2D button to view the fame in 3D.

The forces diagram and deflection diagram can be animated or scaled using the
sliders.

When viewing deflections remember to select the appropriate Strength / Service
Factor.
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The steel beams were initially set to Autodesign, TSD will assign an initial size for the
purpose of analysis (notice the large deflections). Home tab > Settings > Section
Defaults.

We will design an appropriate size later in the exercise.

12.4 Filtering Results Graphically

You can further filter/simplify the current view by using the scene contents to turn off/on elements.

Step 1. Open the Scene Contents and turn off the top and bottom booms display.

Step 2. Turn them back on when finished.

12.5 Tabulated Results

Numerical input and results data can be obtained in tabulated form.

Step 1. Select the Analysis tab and then Tabular Data.
Step 2. Then select a number of inputs and results data tables from the drop down list on the

ribbon.
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13 Right Click Context Menu

In any view, hovering the mouse pointer over any element will shade the outline of that element.

Right click on the mouse, hover over an element to produce more options for modelling /
information / design.

Step 1. Edit Member – Same options as the Properties window, individual modification of the
element but in a pop up dialogue.

Step 2. Open Load Analysis View – Choose this option to see detailed individual analysis results
from the altered ribbon options.

Remember to pick the appropriate loadcase/combination.
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You can also adjust the Distance property by hovering the cursor over the vertical
red line in the loading analysis view. When the cursor changes to hold the left
mouse button down and drag the cursor to a new location. The Distance property
is adjusted and co-existent values are displayed for the distance set.
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14 The Solver View

The underlying creation of the solver model can be viewed and settings for support fixities, member
releases etc. can be interrogated / edited.

Step 1. To open the Solver View click the toggle button in the bottom right of the window.

Step 2. To see the properties of any element – left click and look to the Properties window.
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15 Creating a More Complex 3D Structure

15.1 Copy Command

We will use the frame to produce the rest of the 3D Structure.

Step 1. Go to Load tab, click on Loadcases command.
Step 2. Delete all the existing loadcases (as shown below) and tick the Calc Automatically option

for “Slab self weight” loadcase.

Step 3. In Structure 3D view and turn on the base Grid Lines display from Scene Contents.
Step 4. Select all the elements of the Frame – **Do not select any gridlines.

Step 5. Go the Edit tab and click the Copy command.

Step 6. Follow the instructions in the yellow information bar – pick the Reference Node at the
location as shown in below.
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Step 7. Pick the new positions of 1/C, D and E.

Step 8. Press Esc twice to exit the operation and clear the selection.

15.2 Placing Concrete Beams

Step 1. Open St. 1 (First Floor) 2D plan view.
Step 2. Go to Model tab and click the Concrete Beam command.
Step 3. Edit the section to be Rectangular 300 x 600 – then save as a property set.
Step 4. Click and drag two boxed to connect the frames.
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15.3 Placing Steel Beams

Step 1. In the current view, click the Steel Beam command
Step 2. Set to AutoDesign in the Properties window
Step 3. Individually pick the intersection points to place them along gridline 2.

15.4 Placing Intermediate Steel Beams

Place intermediate steel beams horizontally between gridlines 1a, 2 and 2a.

Step 4. Still in create beam mode place the cursor over the vertical beam and pick the central
node point and pick the similar point on the other corresponding beam.
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The forces diagram and deflection diagram can be animated or scaled using the
sliders.

Step 5. Repeat this process for all steel bays.
Step 6. Add addition steel beams as shown below, all split at a 50% ratio.

15.5 Creating Slabs

In the concrete area of the floor we will be placing Slabs on Beams and in the steel area placing a
Composite Slab.

15.5.1 Concrete slabs

Step 1. Still in the 2D plan view, click the Slab on Beams command.
Step 2. In the Properties window, enter slab depth to be 200mm, C32/40, with Two-way

Decomposition.
Step 3. Use the click and drag method to create all slabs in individual bays.

Slabs can be placed by picking the individual points – untick the option Select bays.
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15.5.2 Composite slabs

Step 1. From the drop list, select the Composite Slabs command.
Step 2. In the Properties window, set to the followings:

· Composite Slab – One-way Decomposition
· Depth – 200mm, C32/40
· Rotated 90 degrees
· Country of Origin UK, manufacturer RLSD
· Reference – Ribdeck AL @ 0.9 Gauge
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Take note of the graphical C.O.G (Centre of Gravity) position as you build the model.

15.6 Deleting and Rotating Slabs

Step 1. Delete and Rotate the following slabs in the model.

Openings which exist in one way decomposition slab are usually framed with beam
elements.

15.7 Openings for Two-way Slab

When the decomposition of the slab is two-way, openings can be placed anywhere within the area.

Step 1. In the Model tab, click the Slab Opening command.
Step 2. Within a two-way slab, single click to pick 1st corner of opening, move the cursor and

single click to pick the diagonal corner of opening.
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The F2 button can be pressed to define offsets and dimensions of the opening.

In the Properties window you have options for shape (rectangular and circular) and
any rotation.
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16 Floor Panel Loading

Step 1. Go to Loads tab and click the Loadcases command.
Step 2. In the Loadcases dialogue, delete the existing Dead, Roof Imposed and Floor Imposed

loadcases.
Step 3. Then create two new loadcases:

· First Floor Additional Dead – Type set as Dead
· First Floor Imposed – Type set as Imposed

Step 4. Ensure for Slab self weight the option Calc Automatically is ticked.

Step 5. Press OK to confirm the above.
Step 6. In the Loading List option, select the loadcase First Floor Additional Dead.

Step 7. Click the Level Load command, set the load value in the Properties window to be 1 kN/m2.
Step 8. Click on any slab panel to apply this load.
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Step 9. Switch the 2D plan view into a 3D view – click on the 3D icon in the bottom right corner.

16.1 Displaying Loading Text

Use the Scene Content to display the magnitude of the loads applied.

Step 1. Open the Scene Contents window and find the Loading option.
Step 2. Open the addition options next to loading and select the Text option then press OK.

Step 3. Switch the loadcase to First Floor Imposed and apply 3.5 kN/m2 on the floor as a Level Load.
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17 Creating 3D Roof Structure

17.1 Creating Eaves Beams

We will now use purlins and eaves beams to connect the remaining frames.

Step 1. Switch to the Structure 3D View.
Step 2. Create a single Steel Beam at the eaves level.
Step 3. Select the steel beam and change its properties to the followings:

· Characteristic to Eaves Beam
· Material type to Cold rolled
· Section to KingSpan Eaves Beams 265x2.0x21 (UK)
· Grade to S450GD

Step 4. Right click on the eaves beam, select Create property set > Span 1 in the context menu.
Step 5. Save this property set as Eaves Beam.
Step 6. Either create and place new eaves beams using the saved property set or use the Copy

function.
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17.2 Creating Purlins

Between the intersections of the curved top boom truss we will place purlins to connect the frame.

Step 1. In the Structure 3D View.
Step 2. Create a single Steel Beam at the first top boom truss node position.
Step 3. Select the steel beam and change to the following properties:

· Characteristic to Purlin
· Material type to Cold rolled
· Section to KingSpan MultiBeam 205x2.0
· Grade to S450GD

Step 4. Save this property set as Purlin (using right click context menu option).
Step 5. Place purlins throughout the structure with a technique of placing place new purlin beam

and then using the Copy / Mirror function.

Copy function:

Step 1. Select all the purlins (using Ctrl key for multiple selection).
Step 2. Following the instructions given in the information bar – first pick on a reference point and

then pick on new location to paste the purlins.
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Mirror function:

Step 1. Pick a Front view from the 3D view cube.
Step 2. Holding the Ctrl key (adding to the selection) and using select entity by window crossing to

select on all purlins.

Drag a window from right to left, having it crosses the purlins – careful not to select
the eaves beam

Step 3. Switch back to 3D perspective view.
Step 4. Go to Edit tab, click the Mirror command.
Step 5. In the Properties window, set MirrorMode to XZPlane.
Step 6. Pick on the central node in the truss as the Reference Node.

Step 7. Press Esc twice to exit the operation and clear the selection.
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17.3 Placing Roof Panels

Roof panels are loading decomposition panel which span in a single direction. They offer no
additional stiffness to the model and must be supported in the span direction by a beam element.

Step 1. In the Model tab pick the Roof Panel command.

Roof or wall panels must be placed in a planer position (no creases in the panel)
otherwise load decomposition cannot occur.

Step 2. Click each corner of the panel in sequence to place the panel.

The panels will highlight in Red and Green when the appropriate node position is
selected.

Step 3. The span direction of the panel of the panel needs to be altered – Select the roof panel item.
Step 4. In the Properties window set the rotation to 90 degrees.

Step 5. Repeat this process and add half of the roof panels taking account of the rotation.
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Step 6. Select the roof panels and use the Mirror command in the XZplane to place the remaining
panels. Pick the central top boom node as the Reference Node.

Step 7. Press Esc twice to exit the operation and clear the selection.

17.4 Loading the Roof Structure

Step 1. Go to the Load tab, click the Loadcases command.
Step 2. In the Loadcases dialogue, create another two new cases –

· Roof Dead – Type set as Dead
· Roof Imposed – Type set as Roof Imposed
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Step 3. Press OK to exit the dialogue.

We will be using Area Loads to place loading on the roof structure.

Step 4. In the Structure 3D view.
Step 5. Select the loadcase Roof Dead from the Loading List option.
Step 6. In the Loads tab, click the Area Loads command.
Step 7. Adjust the load value in the Properties window to 0.6 kN/m2.
Step 8. Pick a Front view and drag a crossing window (from right to left) across the roof panel items.

Step 9. Repeat the same process to apply Area Load of 0.5 kN/m2 for Roof Imposed loadcase.
Step 10. Check the applied loading in the Structure 3D View.

Remember to use the Scene Contents to turn on the load value text display.

Step 11. Set the loadcase to None to remove the loading from the view.
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18 Steel Floor

18.1 Placing Steel Beams

At the truss bottom boom level we will place a floor comprised of steel  beams and  steel deck of 200
mm thick.

When any floor is established in the model the Floors option must be ticked in the Construction
Levels.

More information on this option can be found in the Help System by pressing F1.

Step 1. In the Model tab, click the Construction Levels command.
Step 2. Place a tick next to Truss Bottom in the Floors option.

Step 3. Open a 2D view of the Truss Bottom level.
Step 4. Use the Steel Beam command in the Model tab, set in Properties window the followings:

· Grade to be S355
· Tick on the option Autodesign
· Save this property set as Steel Beam

Step 5. Establish the floor layout shown below – Place the primary beam as shown below in a
single bay.
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Step 6. Now place the secondary beams at ¼ point , ½ point and ¾ point in the single bay.

Step 7. Now use the Copy command to establish the floor plate shown below.

18.2 Placing a Steel Deck

Step 1. In the Model tab, in the slab area use the drop list to select the Steel Deck command.

Step 2. In the Properties window, set the slab Depth to be
200mm.

Step 3. Drag a window encompassing the whole floor area to place the steel deck items.
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18.3 Steel Floor Loading

Step 1. Create a new loadcase Imposed Steel Floor with Type set as Imposed.

Step 2. Place a Slab Load of 1.5kN/m2 by clicking any slab item on that level.

18.4 Combinations

Since new loadcases have been added to the model, the current load combination list are not up to
date.

Step 3. Pick the same options as previous.
Step 4. In the Load tab, click the Combination command.
Step 5. Delete the previous established combinations.
Step 6. Click the Generate… button in the combination dialogue (at bottom right).
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Step 7. Pick the option of Table A1.2(B) – Eq 6.10a&b.
Step 8. Untick all other combinations options.
Step 9. Press Finish.

Step 10. Check the individual combinations that the combinations contain all the loadcases.

Step 11. Press OK to exit the combinations dialogue.
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19 3D Model Validation and Analysis Results

With the 3D model created we will perform the validation to check for modelling errors and then the
analysis for any issues in the solver.

19.1 Validation

Step 1. Press the Validate button either off the quick access button or the end of the ribbon.

Step 2. Check in the Status tab under Project Workspace to see if there are any issues reported.

The model has passed validation showing green ticks next to Model and Model
Geometry.

19.2 Analysis Options

Before we undertake the analysis we will have a look at the analysis option for the model created.

Step 1. In the Analyse tab, click the Options command.

The following dialogue is displayed – here is where we can control the different options for analysis
and the control of inertias in the model. These settings will be carried through to the design module

As shown below we have made alterations to inertial properties concerning concrete and separated
them  to  be  ‘Cracked’  and  ‘Uncracked’. Each element will allow you to specify which option is
applicable.
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19.3 Analysis Process

Step 1. Open the Show Process window.
Step 2. Run the 1st Order Linear analysis in the Analyse tab.
Step 3. Select to analyse all loadcases and combinations and press OK.

Step 4. Check the process window to ensure the analysis has completed.
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19.4 Loading Summaries

Step 1. Check the Loading Summaries in the Loading tab under Project Workspace. Check for
load applied on the structure against the total reaction.

The green ticks in the Project workspace window indicates correct loading
decomposition.

19.5 Deflections

Step 1. Check the deflections of the structure by switching to the Results View.

Step 2. Display the following results in the 3D view:

· Vertical Z Deflections
· Combination - STR3-1.35xG+1.5Q+1.5RQ
· Vertical Z Reactions
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Remember you can visualise deflection at service and ultimate.

Step 3. Explore other diagrams and tabulated results – ensure all deflections are less than 1m.

It is always recommended that you have a stable model (deflections less than
1m in all directions) before you conduct any form of design.
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20 The Design

TSD will combine the Analysis and Design of elements and reinforcement into a single operation.
Currently the only materials which are allowed for design are Steel and Concrete.

In the Design tab, the commands for design are split by material - Steel, Concrete or
All and then by the terms Gravity, Static and RSA.

20.1 Design Options

Before any design is undertaken the Design Options for the model must be reviewed.

· Click the Options command and the following dialogue is displayed – this area is explained
in more detail in the material specific courses but we will review some of the options.

20.1.1 Analysis

As mentioned before the analysis and design is performed as a single operation, but this dialogue
you have control of which type of analysis is performed (1st Order, P-Delta, 2nd Order).

TSD will pick the appropriate analysis type depending if non-linear geometric objects
existed in the model. Example – tension-only bracing, compression/tension only
spring or support.

More information on this topic will be discussed in the later chapter.
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20.1.2 Concrete

This is the reinforcement settings for individual concrete elements.

20.1.3 Design Forces

During the design process the individual elements can encounter other (secondary) forces
preventing the design (example, axial force encountered in a concrete beam design).

Any design forces smaller than the values defined here are ignored in the design calculations.

This dialogue gives a permissible limit which is controlled by the user.

Some forces greater than the values set above will be ignored by the individual
member design, since they cannot be handled by the element type. The element
will be flagged as a warning (a yellow triangle) to advise of this and the member
design results will clearly detail this.
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20.1.4 Design Groups

Design groups are based on the geometric properties of the element, vertical or horizontal.
These elements are placed together in a group and the worst case design  of  section  or
reinforcement applied to all members of the same group.

Concrete elements are grouped together while steel elements are designed
individually.
Individual groups can be controlled via the Project Workspace – Groups tab.

More information on this topic will be discussed in the later chapter.

20.1.5 Autodesign

TSD predominately has two modes for design:

· Design Mode – automatically select a section size / reinforcement which is adequate to pass
the design of the element

· Check Mode – a section size / reinforcement is already prescribed and the program will check
if they are adequate to pass the design of the elements.

The Autodesign option controls what happens to individual steel and concrete member
Autodesign settings at the end of the design process.
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The first two options determine if the individual members Autodesign setting are cleared or not
as follows:

· Always - The Autodesign setting is automatically cleared at the end of the design process -
putting every member into check mode.

· Never - The Autodesign setting (either checked, or unchecked) is always retained at the end
of the design process.

The third option “When check status is at worst” makes the change from Autodesign, conditional
upon the design status (following a design) as follows:

· Pass - The Autodesign setting is only automatically cleared at the end of the design process
for members with design status: Pass.

· Warning - The Autodesign setting is only automatically cleared at the end of the design
process for members with design status: Pass, or Warning.

· Fail - The Autodesign setting is only automatically cleared at the end of the design process
for members with design status: Pass, Warning, or Fail.

· Invalid - The Autodesign setting is only automatically cleared at the end of the design process
for members with design status: Pass, Warning, Fail or Invalid.

· Beyond Scope - The Autodesign setting is only automatically cleared at the end of the design
process for members with design status: Pass, Warning, Fail, Invalid or Beyond Scope.

The most practical use of the “When check is at worst” status would be to set it to
Pass and start with all members in Autodesign mode. At the end of the first design
run passing members would be set to “Check mode”, allowing you to focus on the
remaining members still in “Autodesign mode”.

For Concrete elements Auto design mode is default set to ‘Never’ – reinforcement is checked
and if failing a manual integration must be performed.

For Steel elements Auto design mode is  default  set  to  ‘Always’ – a passing section is always
sought for the design.

20.2 Gravity Design

For initial sizing of steel members and reinforcement we can perform a gravity design which will only
analyse and design elements/reinforcement to the gravity combinations.

Only 2 combinations have been created and classified as Gravity, therefore only
these two combinations will be analysed and the design produced from the results.
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Step 1. Open the Show Process window.
Step 2. In the Design tab, click the Design All (Gravity) command.

This button will design both steel and concrete elements (for gravity combinations).

The following message will appear in the bottom right of the screen.

Step 3. Review the Show Process window to ensure all aspects of the design have been completed.

Step 4. Check the Loading Summaries in the Loading tab under Project Workspace. Check for
load applied on the structure against the total reaction.

Step 5. Check the deflections for the structure in the Results View.

20.3 Design Review Mode

Once a design has been undertaken you are automatically switched to the Review View where the
model design status and other information can be displayed on the screen and reviewed.
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Most these options will be covered in detail in the later chapters, but we will review a few of them
now.

20.3.1 Design Status

The Design - Status command uses colour codes to graphically display the design status of each
member.

The key displays Pass, Fail, Warning, Error, Beyond Scope or Unknown status of the entities.

20.3.2 Design Ratio

The Design - Ratio command uses colour codes to graphically display the design ratio of each
member.
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The ‘N/A’ colour code is assigned to those members that are either beyond scope
or have yet to be designed.

20.3.3 Show\Alter State – Auto\Check Design

Graphical switch for concrete/steel elements from Design to Check Mode.

Each member is colour coded to indicate its Autodesign setting (On or Off).

· Clicking on an individual member toggles its Autodesign setting.

· Dragging  a  box  from  left  to  right toggles  the  Autodesign  setting  for  all  members  totally
enclosed by the box.

· Dragging a box from right to left toggles the Autodesign setting for all members that are
either enclosed by the box, or are cut by the box perimeter.

· Depressing the SHIFT key and dragging a line toggles the Autodesign setting for all members
that cross the line.
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20.3.4 Show\Alter State – Steel button

The Steel command provides a means to graphically review and modify the section size and or grade
applied to steel members.

To graphically copy the section size and grade between members:

1. Click Review > Auto\Check Design and ensure that Autodesign is off for the members in
question then click Review > Steel

2. In the Properties window, select the parameter to copy (Section, Grade or Both).

3. Click on the member containing the steel to be copied.

4. Click on the member(s) to which you want to apply the steel.

The member clicked on has to be of the same type (beam, column, or brace) as the
source member.

To change the source being copied from, press Esc and then select a different
member.

20.3.5 Design Tabular Data

Tabular design information such as Design Summary, Sway, and Storey Drift etc. can be displayed on
the screen.
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This will open up another window – select the relevant options.

20.4 Right Click Context Menu

Individual element design information can be displayed by right click on an element in the model.

20.4.1 Concrete Elements

20.4.2 Check Member – Concrete

Check Member will display the design results for that element to the set design code of practice.
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Showing summary as well as individual element information by expanding the tree.
Highlight any option in the tree to display the information.

20.4.3 Design Member – Concrete

An individual element can be auto-designed to find a reinforcement design configuration to all
combinations.

The blue exclamation mark indicates the critical option in the design, along with any
relevant causes in the codes of practice.

Individual combination design results will be listed in the tree – but the critical
combination listed in the summary.
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20.4.4 Design… - Interactive Reinforcement Concrete Design

Manual interactive reinforcement design can be conducted for all concrete elements in the project.

· Longitudinal Bar Design

· Link Design

· Interaction Diagrams
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20.4.5 Generating Detailed Drawings

Single element DXF drawing can be produced showing reinforcement details for the element.
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20.4.6 Report for Member

A simple defaulted element report can be obtained – these can be modified as explained later in the
manual.

20.5 Steel Elements
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20.5.1 Check Member – Steel

This provides the steel section size design results to a specific code of practice.

All aspects of the design can be interrogated and the blue exclamation mark
indicated the critical condition.

20.5.2 Design Member – Steel

An individual steel element can be auto-designed to find a section size, satisfying all design
combinations which have been analysed.
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20.5.3 Generating Detail Drawing – Steel

Individual element drawing.

20.5.4 Report for Member – Steel

A simple defaulted element report can be obtained – these can be modified as explained later in the
manual.
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20.6 Design Status

Once a design has been conducted the status of the model can be visualised.

(1) Load Condition – Wind / Seismic

(2) Analysis Condition

(3) Design Condition Steel Gravity

(4) Design Condition Steel All

(5) Design Condition Concrete Gravity

(6) Design Condition Concrete All

§ Red Cross – Not valid
§ Green Tick – Valid

Step 1. Edit a steel beam by double left clicking on it - change the section size to UKB 533x165x66
and press OK.

The graphical status area shows question marks.

§ This indicates that the model status is unknown and there has been some of
adjustment which has invalidated the design.

§ TSD will retain (where possible) the previous design/analysis results obtained in
the model.

Step 2. Right click on the same steel beam as in above and select Check Member.
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§ Since  the  previous  results  are  retained,  TSD  can  perform  a  check  on  this
member.

§ A word of caution if the end fixities are changed and the analysis and design not
updated, the element may show design results not to the correct forces.

Step 3. Right click again on the same steel beam and select Design Member.

The individual element will run through the Autodesign process and select a section
size which is adequate for the previous analysis results.

20.6.1 Analysis warnings

As mentioned previously the design procedure can encounter other analysis forces which will
invalidate the design – these are control in the design options.

If any element has a force exceeding the values stated above, it will be highlighted as a warning.

The design will still continue but ignoring this offending force value. This value can be seen in the
Forces Ignored area of the design results.
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Step 4. Re-run the Design All (Static) for the model to update the analysis and design results.
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21 Lateral Loading

21.1 EHF’s – Equivalent Horizontal Forces

The application of EHF’s (Equivalent Horizontal Loads) and wind will be covered in the following
sections.

For  a  gravity  design  a  model  can  have  all  elements  passing,  but  when  lateral
combinations are applied and checked, these elements can now fail.

EHF’s are automatically calculated by TSD and can be easily applied to the model

EHF’s are used to represent frame imperfections. The Eurocode requires they are applied to all
combinations. (Lateral wind combinations therefore should also have EHF’s applied).

EHF’s are automatically derived from the factored load cases within the current combination. They
are applied in the analysis as a horizontal force at each beam column intersection with a magnitude
of 0.5% of the vertical load in the column at the column/beam intersection.

They are applied to the structure in X and Y global directions as follows: EHF X+, EHF X-, EHF Y+ and
EHF Y-

However they are then combined to act in the +Dir1, -Dir1, +Dir2 and -Dir2 directions (because many
structures do not have their primary axes along X and Y).

This is achieved by applying the loads themselves in global X and Y as above, and then using the
combination factors to set them in Dir1 and Dir2 as required.

Example if the angle between X and Dir1 is +60 degs - TSD applies +X factor 0.5 and
+Y factor 0.866. (i.e. cos 60 degs and sin 60 degs).

The net result is that any combination is able to have up to 2 EHFs applied within it - one from X (+
or -) and one from Y (+ or -).

In addition, you are able to set up the combinations manually and apply factors to each as required.

21.2 EHF Control

The control for EHF can be found in the Model  Settings  >  EHF and this is used to control the
magnitude of the EHF applied to the structure.
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· Height of structure - to specify the effective height of the structure to be used in the EHF
calculations.

· Set Default button - sets the height to the highest construction level.

· Number of Columns in X and Y directions – default set as 1

In the Eurocode Cl 5.2(5) the calculation of the reduction factor am depends on the
number of contributing members, m.

Valid input for “m” in the X and Y directions is any whole number from 1 to 1000.
The default value is 1 which results in am = 1.000. If a value of 1000 is entered then
am would reduce to 0.707.

· Global initial sway imperfections - Displays the calculated alpha (a) and phi (f) values for the
above input.

21.3 Applying Equivalent Horizontal Forces (EHF’s)

Keeping the defaulted values in the EHF settings, we will apply EHFs to our structure.

Step 1. In the Load tab, click the Load Combination command.
Step 2. In the combinations dialogue, delete all previous combinations.
Step 3. Press the Generate… button.

Step 4. Pick the option “Table A1.2(B) – Eq 6.20a&b”.
Step 5. Un-tick the options Geo, Accidental and Seismic combinations - press Next.
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Step 6. Accept the defaults on the combinations equation generator – press Next.

Step 7. Accept defaults on the service factor generator – press Next.

Step 8. Tick all directions (Dir1+, Dir1-, Dir2+ & Dir2-) to apply EHF’s to the repeated gravity
equations.

Step 9. Press Finish to exit the generator and OK to exit the combination dialogue.

Total 10 combinations are created from the Combination Generator.
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21.4 Renumbering Loadcases and Combinations

The Loadcase and Combination numbering has continued from the previous deleted set, we will
renumber them to start from 0 again.

Step 1. In the Project Workspace, select the Loading tab.
Step 2. Right click over the title Loadcases and pick the option Renumber.

Step 3. Repeat the step above for combinations.
Step 4. Perform a complete design on all loadcases and combinations.

a. Check the Loading Summary
b. Check the Deflections of the Structure
c. Check the Element Design
d. Check the Sway Results from the Tabulated Data



21 Lateral Loading 141 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

21.5 Wind Loading – Manual Input

To place any type of loading on the structure an empty loadcase has to be created.

Step 1. In the Load tab, select Loadcases command.
Step 2. Add a new loadcase “Wind in X” and set the Type to be Wind - press OK.
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Step 3. Go to Structure 3D view and select the Wind in X loadcase from the loading list option.

21.5.1 Nodal Loading

Step 1. In the Load tab, click the Nodal Load command.
Step 2. Define in the Properties window a load value of 15kN in the X direction.

Step 3. In the Structure 3D view pick a beam to beam or beam to column intersection point to
place a nodal load.
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Remember to use the Scene Contents to display the load text value.

21.5.2 Element Loading

Step 1. In the Load tab and click the Full UDL command.
Step 2. Define in the Properties window a load value of 5kN/m in Global X direction.

Step 3. In the 3D view, click on a perimeter beam to place the full UDL on it.

When a member load is placed on an element this will induce bending which may
invalidate the design (i.e. minor axis on simple beams).

21.5.3 Panel Loading

To place an area load over several elements a decomposition tool must be applied first. Wall and
Roof panels are used to decompose an area load to the connecting elements. These panels are one
way spanning and have to option to decompose as nodal loads or UDLs (Walls).

Roofs are placed as flat or sloped panels, Walls are placed vertically.
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We will place a Wind Panel along gridline B.

To place a wind panel all intersection points must be placed in sequence and must
be planer.

Step 1. In the Model tab and pick the Wall Panel command.
Step 2. Pick the intersection points in sequence to place a panel (Remember to pick every

intersection point on the top boom timber truss).
Step 3. Either double left click the last point to end the panel or single click back to the start to

finish the creation of the wall panel.

21.5.4 Wall Panel Orientation and Span Direction Decomposition

Wall panels have an inner and outer orientation which is determined by the direction which the
sequence of nodes are picked.

Nodes picked in an Anti-clockwise direction will place an opaque blue indicating the Outward side.
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Nodes picked in a Clockwise direction will place a solid blue indicating the Inward side.

For load decomposition to occur – the Outward face (opaque blue) must be
shown.

21.5.5 Wall Panel Changing Orientation

To change the orientation of the wall panel use the Reverse command in the Edit tab.

Step 1. If you have placed the wall panel with the inward face showing – reverse the orientation
using the technique described above.

21.5.6 Applying Panel Loading

Step 1. In the Load tab, pick the Area Load command.
Step 2. Apply a load value of 5kN/m2 in the Global X direction on the panel by clicking on it.
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This loadcase can now be merged in a combination in the usual manner.

Step 3. Delete the Loadcase Wind in X.

21.6 Automated Wind Loading

21.6.1 The Wind Wizard

TSD has inbuilt an automated wind loading component, which can be used to apply lateral loading
on your structure. Before this can be used, the structure need to be encased in decomposition Roof
and Wall panels.

Step 1. Place Wall Panels on the remaining vertical faces of the structure. Ensure that the
Outward face orientation is facing you.

Step 2. Check the panel orientation by rotating the model using the right mouse button.
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Step 3. In the Load tab, pick the Wind Wizard command.

Step 4. Pick the following options in the wizard and press Next.

Step 5. Fill in the fields as shown below for Basic Data and press Next.

Step 6. Fill in the fields as shown below for Rougness and Obstructions and press Next.

Step 7. Press the Details… button to report the wind data then press Finish.
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21.6.2 The Wind View

Step 1. Activate the Wind View mode by selecting the Icon in the lower right or right click the
Structure 3D tab.

Step 2. Select the Wind tab in the Project Workspace.

Step 3. Wind information can be displayed via the options and the ribbon and other directions can
be viewed vied the drop down option or double clicking the direction in the project window.
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21.6.3 Wind Loadcases

Step 1. In the Load tab and click the Wind Loadcases command.

Step 2. In the Wind Loadcases dialogue press the Auto button and press OK.

21.6.4 Reviewing the Decomposed Wind Loads

Step 1. Switch back to the Zone Loads tab and select Zone Loads option, and select a Wind
Loadcase from the Loading List option.
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21.6.5 Generating Combinations

Once the wind load cases have been established the lateral combinations can be created via the
generator.

Step 1. In the Load tab, click the Combination command.
Step 2. In the Combinations dialogue, delete all previous created combinations.
Step 3. Press the Generate… button.
Step 4. Follow the steps through the generator and establish the EHF and Wind Combinations.
Step 5. Only check the first combination for the EHFs and press Finish.

Please note that all combinations must include EHF forces in the design.
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Step 6. Renumber the loadcases and combinations.

Step 7. Perform the Design All (Static) command and then check the followings:

a. Design process – Show Process window

b. Design status – Status tab in Project Workspace

The solver is indicating a large deflection in the model.
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c. Loading Summary – Loading tab in Project Workspace

d. Deflections – Results View

The structure clearly has lateral issues in the perpendicular direction to the truss -
try and stabilise the structure by adding other structural elements (Bracings, Walls,
Etc.) or by altering the fixity of the structure.

The status of the project shows that the design is indicating a “Pass” but due to
the warnings in the analysis – the design must be viewed with extreme caution.
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22 Output

22.1 Predefined Reports

TSD has inbuilt predefined standard reports which can be viewed for your structure.

Step 1. Select the Report tab on the ribbon.
Step 2. On the Select option, click on the drop down list options to see the available reports.
Step 3. Highlight a report and click the Show Report command.

The report above has been generated by adding individual components.

22.2 Individual Report Components – Model Reports

Step 1. Click the Model Report command which contains overall model information.
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Generate the following report:

Step 2. Click the Add button and create a report name called Sway, Drift & Storey Shears and press
the >>Active button to set as default.

Step 3. In the Chapters and Options, left click on the Picture component and drag it into the Report
Structure.

22.2.1 Report Component Control

The Picture component just added to the report structure can be Filtered to specify the required
view and any specific loading information.

Step 4. Right click on the Picture and under Model Filter select Edit/New…

Step 5. Press the Add button and highlight the Frame type.
Step 6. Tick FRM B item, then change the name to Frame B then press OK.
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Step 7. In the Chapters and Options, expand the Analysis option and add the Sway, Drift and
Storey Shears component to the Report Structure – Ensure the filter applied is for the whole
structure and press OK.

Step 8. Press the Show Report command to display the report on the screen.

Created Report:
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Storey Shears:
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22.3 Structural Element Reports

Establishing the report contents for an individual concrete beam are found in the Member Reports
command.

Step 1. Click the Member Reports command and select the Member Type to be Concrete Beam.
Step 2. Click Add button to create a new report and set it as Active.

Step 3. Pick the following components to be included in the report – note each component will have
its own filter which can be adjusted and press OK.

22.3.1 Quick Filter Report Options

Step 4. In the Report tab pick the Levels filter option.

Step 5. Add a First Floor filter and give the name of First Floor - press OK.
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Step 6. Click the Model Report command and Add a new report called Concrete Beams and set to
Active.

Step 7. Add the Reinforced Concrete component to the Report Structure.
Step 8. Add the predefined filter of First Floor and press OK.

Step 9. Press the Show Report command to display the report on the screen.
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22.4 Exporting Reports

Reports can be exported to TEDDS, Excel, PDF, and Word – click the appropriate export button when
viewing a report.

22.5 Saving Pictures

Any graphical view can be saved to a picture file by setting up the view required – right click anywhere
on the screen and pick the option Save Screenshot.
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22.6 Engineering Drawings

Drawings are generally created from the Draw tab. A wide range of drawing types and styles are
available which can be customised to meet your specific requirements. Single member drawings can
also be created from the right click context menu.

· Edit – Drawing Settings Menu

· Drawing Management - Opens a dialog for the generation and laying out of multiple
drawings on to a single drawing sheet. The dialog can also be used to manage drawing
revisions and history.

· General Arrangement – Create multi material plans, sections and elevations

· Slab Detailing – Generate a reinforcement slab detail drawing

· Beam Schedule – Beam Reinforcement Engineering Drawings

· Column Schedule - Column Reinforcement Engineering Drawings

· Wall Schedule – Wall Reinforcement Engineering Drawings
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22.6.1 Creating 2D Multi Material Drawing

Step 1. Obtain a 2D plan view of the First Floor.
Step 2. In the Draw tab, click the General Arrangement command.
Step 3. Accept the defaults in the pop up dialogue.

22.6.2 Creating 2D End Reaction Drawing

Step 1. Obtain a 2D plan view of the First Floor.
Step 2. Switch to the Results View.
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Step 3. Select a Loadcase / Combination.

Step 4. In the Draw tab, click the General Arrangement command.
Step 5. Select the drawing type to be Beam End Forces and 1:50 scale - press OK.
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23 Analysis and Design of Concrete Structures

In this session, we will look at the analysis and design of concrete structures.

Step 1. Open the model TSD Concrete Design Fundamentals Model 3 - Element Design.tsmd.

23.1 Analysis and Design Options

As mentioned earlier, before any analyses or designs are undertaken, all of the analysis and design
options should be checked thoroughly to ensure that elements are designed as required.

Step 2. Go to the Analyse tab and click the Options command to review the Analysis Options, then
click OK to confirm them.

Step 3. Go to the Design tab and click the Options command to review the Design Options, then
click OK to confirm them.

23.2 Analysis and Design Procedure

TSD can run multiple analyses on the model and then design all concrete frame elements (excluding
slabs) for all gravity and lateral loads in one go.  This is done by clicking the Design Concrete (Static)
button on the Design tab.

There is also a Design Concrete (Gravity) button available, which will only deal with
the vertical loads.

This process goes through a series of steps, in part controlled by the Design Options, with the key
stages mentioned below.

You can monitor the progress of the design process by clicking the Show Process
button in the bottom left corner of the screen before clicking a Design command.

Elements designed during this process will be designed for the worst case results from all analyses
completed, based on the element’s Autodesign properties, and the Design Group that it belongs to.

· Validation – the purpose of validation is to trap out errors and potential problems with the
model that will likely either cause the analysis or design process to fail, or produce potentially
unexpected results.  If any issues are found, they will be reported as either warnings or
errors, in the Status tree.   Errors  MUST  be  corrected  to  allow  the  analysis  and  design
procedure to be completed, and will be highlighted with a red cross.  The analysis and design
process should complete if warnings are present, but they should be reviewed and corrected
if deems necessary.

You can double click on the warning and error messages in the status tree to locate
the issues in an appropriate view of the model.

The validation process will also report some information for points of interest, and stages that fully
pass will be highlighted with green ticks.
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· Load Decomposition – slab loads are decomposed into the frame members using FE analysis.

· 3D Analysis – this will analyse the whole model at once, following the analysis and design
options, and can either treat the slabs as diaphragms (default), or mesh the slabs.

· Grillage Chasedown – this will complete a chasedown of load using the sub-models of each
floor, from top to bottom, without the slabs being meshed.

· FE Chasedown – this will complete a chasedown of load using the sub-models of each floor,
from top to bottom, meshing the slabs at every level.

· Design of all frame elements – once the structure is fully analysed, TSD will perform either
a  full  Auto  Design  or  a  Check  Design  of  all  frame  elements  in  the  model,  based  on  their
Autodesign property status.

The default for concrete elements is always set as Auto Design.

23.2.1 Auto Design and Check Design

When TSD performs a design, it will either do an Auto Design or a Check Design, depending on its
Autodesign property status, found in the Properties window for that element.

An Auto Design will complete a new full design based on the newly updated results.  There are two
types of autodesign available; either Minima or Current, also specified in the element’s Properties
window.

· Minima option removes any current bar arrangement and starts the design from the
minimum allowable bar sizes.

· Current option starts from the current bar arrangement.

A Check Design will check the element’s already existing design against the updated analysis results
and will report a pass or fail.

23.2.2 Design Groups

To allow for a quick and efficient design process, all concrete beams and columns are automatically
placed into Design Groups.

Design Groups have no specific engineering data associated with them and are simply a unique name
for a collection of similar frame elements.  They are formed automatically based on span lengths,
number of spans, section sizes and various other criteria.

The result of using design groups means that every element within the group will have the same
reinforcement, and provided they can all be designed successfully, they will all work for all results of
all the different analyses completed.
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The Design Groups can be viewed using the Groups tab in the project workspace.  This window allows
you to do a variety of things, including editing the groups and re-grouping the elements.

The topic of Design Groups will be discussed in more detail in a later exercise.

You  will  probably  notice  that  there  are  also Detailing Groups listed  here,  which  relate  to  the
generation of detail drawings.  These too will be discussed in more detail later.

23.2.3 Complete the Analysis and Design

Having reviewed the Analysis and Design Options and understanding the Autodesign and Design
Group functionality, the analysis of the model and design of all frame elements can now be
completed.  Note that slabs are designed using a separate process that will be covered later in this
course.

Step 1. Click the Show Process button in the bottom left corner the screen to open the Process
window.

Step 2. Go to the Design tab and click the Design Concrete (Static) command.
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23.3 Reviewing the Overall Design Status

Once the Design Concrete (Static) process is complete, the View Mode of your active scene view will
automatically change to the Review View mode, and the newly-created Review tab will be activated.
The initial view will show the graphical Design Status of all concrete frame elements in the model to
see if they have passed or failed, or if there are any other issues with them.

23.3.1 Review tab

The Review tab contains a lot of different tools to get a good overall view of the model.  Some of the
key options for reviewing the concrete frame element design statuses are:

· Design Status – this option shows whether the frame elements in the active scene view are
passing or failing the design.  It  also highlights any elements that have errors or warnings
against them, or if the design of an element is beyond the scope.  Any undesigned elements
will be shown to have an Unknown status

· Design Ratio –  switching to  this  review mode allows you to  see how close to  its  limit  an
element’s design is.  Elements are grouped together based on their design utilisation ratios

· Depth Ratio – this option colour codes all the concrete beams in the model to indicate their
span to depth utilisation ratios

There are also a number of Slab Design review ribbons available on the Review tab, but these will
be discussed later.

Step 1. Try switching between the options mentioned above to review the design status of the
model
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23.4 Reviewing the Analysis Results

Once an analysis has been completed, whether in isolation or as part of the Design Concrete (Static)
procedure, the results for all of the completed analyses can be interrogated by manually switching
the view mode to the Results View, and a newly-created Results tab will be activated.

23.4.1 How to View the Results

Once in the Results View mode for a particular view, there are some settings you need to check to
make sure you’re displaying the results you want:

· Scene View – as the Scene Mode setting is retained for each Scene View, you need to first
ensure that you have the right Scene View active, and then make sure that you are in the
Results View Scene Mode and have the Results tab selected.

· Analysis Result Type – in the Result Type group of the Results tab, make sure you select the
appropriate analysis type.  Having completed the Concrete Design (All) process, the
appropriate options will be 1st Order Linear, FE Chasedown and Grillage Chasedown by
default.

As mentioned earlier, each of these analyses do different things so their results will vary.

· Load Type – all results that are displayed are for the particular load case, combination or
envelope that is selected in the Loading Drop List.  If you are seeing no results after activating
a particular results option from the Results tab, then you may not have a load type selected.

Once you have the view set up as required, you can view the analysis results by selecting one or more
of the options on the Results tab.

Step 1. Set up your Structure 3D to display the results for Z direction axial support reactions and
the axial load 1D results for  the Dead loadcase, based on the 1st Order Linear analysis
results.
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23.4.2 Viewing Results for the Whole Model

There are a variety of different results that can be viewed by using the various options on the Results
tab.  These include:

· Support Reactions – view axial and moment support reactions in all 3 directions individually,
combined axial or moment reactions, or total reactions.

· 1D Results – displays the axial force, torsion, moments and shears in the major and minor
axes for all columns and beams in the model.

· Deflections –  view  deflections  in  the  3  global  directions,  2  local  directions,  or  total
deflections.

· Sway and Storey Shear – review the effects predominantly caused by lateral forces.

· Equivalent Horizontal Forces – see the EHFs/NHFs and seismic loads applied to the model

· 2D Results – these options display contours in the walls, and the slabs if you’re viewing the
results for the FE Chasedown analysis, and can display axial forces, moments and design
moments.

· AsReq –  shows the area of  steel  required in  the top and bottom of  the slabs  in  the two
directions.

· 2D Deflections – displays the deflections in the walls and slabs using contours.

· 2D Wall Results – shows the axial force, torsion, moments and shears in the major and minor
axes for the walls, in a similar style to the 1D Results for the columns and beams.

Some of these results are only available, or only make sense, in certain views – i.e. 2D or 3D.  You
can also view multiple scene views, displaying different results at the same time, to allow
comparisons.

Note that slab results can only be seen when viewing results for an analysis that includes the slabs –
as default, this will just be the FE Chasedown.

Step 1. Try viewing some different results for some different scene views.
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23.4.3 Slab Strips

Whilst the slab design process, which will be discussed in detail later, utilises slab strips automatically
and takes them much further, you may wish to cut some strips of the fly and view their results too.
This can be done by clicking the Create Strip command on the Results tab.

Note that you must be in a 2D Plan View to be able to create slab strips.

Once the Create Strip command is active, the strip properties will be displayed in the Properties
window.

Here, you can define the width of the strip at the start and end of the strip, the number of points
and stations within the strip, as well as choose from the following Result Types:

· Average – the results for all points across the width of the strip are calculated using weighted
averages of the shell elements local to each point.  An average value is then calculated for
all  points across the width of the strip at that station, and the process is repeated for all
stations along the length of the strip, which generates the strip results and diagrams.

· Maximum – this option follows the same method as the Average option above, but uses the
maximum point value across the width for the strip for each station along its length, to
generate the results and diagrams.

· Centreline – this option only calculates the weighted average values for the stations along
the centreline of the strip, and ignores all of the points across the width of the strip.
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Once you have set up the properties for the strip, it can be inserted into the plan view by first left-
clicking to define the start point of the strip, then left-clicking again to define the end point.

Once the strip is created, you can view its results by selecting one of the 2D Strip Results options on
the Results ribbon tab, when viewing either 2D or 3D scene views.

Alternatively, provided you have the Result Strips option ticked in the Scene Content, you can select
the strip, right click over it, and choose Open Load Analysis View.  This will create a new Scene View,
displaying the relative displacement, shear, moment, design moment and the area of steel required.

Step 1. Try creating a couple of slab strips and view their results.
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23.4.4 Viewing Frame Element Analysis Results

As well as being able to view the analysis results for the model as a whole, you can also view the
results for individual frame elements – i.e. columns and beams.  These element results can be
accessed by selecting the element in question, right-clicking over it, and choosing Open Load
Analysis View.

A new scene view will be created and a Loading Analysis tab will also automatically open.  This will
allow you to choose which results are displayed and which analysis they come from.  The default is
to display the major axis results, including loading, moment, shear and relative deflection.  As with
all results views, the results displayed will be based on whichever load option you have selected in
the Loading drop list.  The Properties window will also help control the information displayed in this
view.

Step 1. Try viewing some frame element results.
Step 2. Save the model.
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24 Interactive Design of RC Columns and Walls

As  you  have  already  seen,  all  frame  elements  can  designed  at  once  by  using  one  of  the  Design
Concrete options on the Design tab.  For a lot of the time, this will be as far as you will need to go
with it.  However, if you want to interrogate the designs of individual elements in more detail, or if
you need to interactively design a member, then there are a variety of tools to enable you to do this.

24.1 Check Member

Once a column has been designed initially, you can do a Check Design on it by right-clicking over it
in your active scene view and selecting Check Member.

A summary of the existing reinforcement placed in that column will be displayed, which will be the
same reinforcement layout as all the other columns in the same design group, along with its status
based on the current analysis results.

You can also view all of the design calculations and checks based on the analysis results for the
specific column you’re looking at by expanding the options down the left hand side.

 The critical checks and results for each stack within the column being checked will be highlighted
with blue exclamation marks on the left hand side of this window.  The right hand pane will display
the  calculations  and  results,  and  clicking  the  arrow  icons  next  to  the  text  will  either  collapse  or
expand the information.

The Settings button will allow you to edit the formatting of the text in the Check Member window.

Walls can be check-designed in the exact same way, except this option is called Check Wall.

Walls are designed independently from each other and don’t use Design Groups.

Step 1. Make sure the Design Concrete (Static) process has been completed.
Step 2. Try using the Check commands to check a few different columns and walls.
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24.2 Design Member

Along with being able to check a column’s existing design, or design all frame elements in a model,
you can also get TSD to design an individual column by right-clicking over it and select Design
Member>static.

The Design Member command carries out an automatic design for that individual column, and then
allows you to view these new design calculations and results for that member.

However, when you choose to Close this window, it applies the same reinforcement selected as part
of the design to all other members in the same Design Group, and then performs a Check Design on
them.

If you happen to use the Design Member command on an element that is not a
critical member in its Design Group, you may find that some other members from
the same group change from a pass to a fail.

Step 1. Use the Groups tab to locate the column design group CRC11.
Step 2. Use the Check Member command to view the current design for column non-critical column

C14, which is located at the gridline intersection (F/3).
Step 3. Close this window and use the Design Member command to redesign this member based

on its own analysis results

The reinforcement in this column has now been reduced from its original design, but this has resulted
in column C13 now failing in its top stack.  This is because C13 was the critical column for the design
of group CRC11.



24 Interactive Design of RC Columns and Walls 175 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

This failure could be removed by either:

· Using the Design Member command on the now failing column.

· Re-designing the group CRC11, as discussed in the previous example.

· Interactively designing the failing column, which will be discussed in detail shortly.

Step 1. Use the Design Member command to design the failing column C13 and have its updated
reinforcement applied to the column C14.

For walls, this option is called Design Wall, and simply does an automatic design for
the individual wall being looked at.

24.3 Interactive Design…

The automatic designs of elements in TSD will generally be more than appropriate for the majority
of cases.  However, if you’d like to check a column or wall for specific reinforcement, or you just want
to adjust the reinforcement automatically selected by the program to see how it affects the design,
you can use the Interactive Design capabilities.  To do this, you simply right click over a column or
wall in your active scene view and choose Interactive Design….

24.3.1 Interactive Design

Once selected, the Interactive Design… option will first perform a check design on the element in
question, and then allow you to edit the existing rebar for each stack of that element, based on its
analysis results.

For columns, you can adjust the principal (corner) and intermediate (edge) longitudinal bar sizes and
their quantity, and the link bar size and spacing.  This is done by selecting the appropriate stack in
the left hand pane, then selecting the required tab on the right and adjusting the various settings.
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As soon as any of these settings are changed, the sketch, design statuses and results are instantly
updated and displayed.  You can also then click the Check button on the right hand side of this
window to perform a check design of the edited reinforcement and view the full design calculations,
as discussed earlier.

Step 1. Open the Interactive Column Design window for the column C13.
Step 2. Try adjusting the reinforcement in the column to see if it can be reduced.
Step 3. Use the Check button to view the updated results.

24.3.2 Interaction Diagrams

Another useful function in this window is the ability to view the Interaction Diagrams for the column
or wall by selecting the Interaction Diagrams tab in the right hand pane.  Once opened, it allows for
further interrogation of the column design, and shows two different diagrams based on the current
reinforcement you have specified in the design.  As soon as you edit the design, these diagrams will
also update.

The diagram on the left shows the axial load capacity against the moment capacity for  the two
directions of the column.  The results for all combinations and for all analyses completed are all
plotted on this diagram, allowing you to quickly see the overall status of the column and how hard
it’s working.

The diagram on the right shows the major axis moment capacity against the minor axis moment
capacity for the axial load from the critical combination.  The one plot displayed on this diagram is
for the same critical combination results, which is calculated as the worst case results from all
combinations, considering all results from all the analyses completed.
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Step 4. Try adjusting the reinforcement placed in column C13 to see how this affects the Interaction
Diagrams.

24.3.3 Detail Drawing

The Detail Drawing button in the Interactive Design window allows you to quickly view a detailed
drawing of the column or wall.  You can make adjustments to the design of the element, and then
instantly create a detailed drawing of it, using whichever CAD program you have installed on your
machine.

The detailed drawing generated by this method will include an elevation drawing of all stacks making
up the whole column or wall, a section drawing for each stack, and a quantities table as default.
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Whilst you’re more likely to generate detail drawings of multiple columns and walls at once using
other functionality in the program, this feature can still be very useful in understanding the design
of the element in question.  The production of detail drawings will be discussed further later in this
course.

Step 5. Generate and review the Detail Drawing for column C13.

24.3.4 Updating the Design Group

As with the Design Member command,  when you click  OK to  confirm the interactive  design of  a
column, the rebar selected in the new design is applied to all of the columns in the same design
group.  A Check Design is then performed on them and their design calculations and statuses will be
instantly updated.  To make this a more productive process, make sure that you interactively design
the critical column(s) from the Design Group by checking the Groups tab – the critical column within
a group is signified with a red exclamation mark.

This does not apply to the Interactive Design of walls, as they are not designed using Design Groups.
Confirming the Interactive Design of a wall simply applies the rebar to the wall that’s been designed.

Step 6. Click OK to confirm the column (C13) design.

24.3.5 Interactive Design of Walls

The Interactive Design of walls works in a very similar way to that of columns, but there are some
slight differences.

The Interactive Wall Design allows you to specify whether you want to use end zones or not, and
whether you want one or two layers of reinforcement.

Wall design also allows you to choose whether you want to use loose bars or mesh reinforcement.
When using loose bars,  you can select  the vertical  bar  size,  the number of  rows of  bars  and any
additional end row bars.  Using mesh has the same options but allows you to choose the mesh size.

As  you  will  have  noticed  with  this  model,  all  of  the  walls  have  a Warning against them and are
highlighted in Amber when viewing the Results View - Design Status.
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When accessing the Interactive Design window  for  any  of  the  walls  in  the  model,  there  are  no
immediately obvious reasons as to why the walls in this model have warnings, as all checks shown
are passing and have green ticks  next  to  them.   This  suggests  that  the issues  are  actually  due to
detailing problems rather than any of the actual design checks having problems.

Clicking the Check button in the Interactive Wall Design window allows you to view all of the design
calculations, as well as any other additional detailing checks completed by the program.

For an example, you can see here by drilling down into these calculations, the issue is with the
concrete cover for the walls.  The cover specified in the wall properties is 25mm, but according to
code checks, the cover needs to be 26mm or greater.

To resolve this issue, do the following:

Step 1. Select all concrete walls in the model.
Step 2. In the Properties window, edit the Nominal Cover to 30mm and press Enter to confirm.
Step 3. Update the design results for all the walls in the model by either repeating the Design

Concrete (Static) process or by using the Check Wall or Design Wall commands for each
wall, one by one.

Step 4. Save the model.
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25 Interactive Design of RC Beams

As with columns, you can get TSD to complete a Check Design or an Auto Design on an individual
beam member, or you can perform an Interactive Beam Design.

25.1 Check Member

In exactly the same way as with columns, you can perform a Check Design on a beam by right-clicking
over it in your active scene view and selecting Check Member.

The Check Member command and window works in exactly the same way as for columns and walls,
except all of the design and detailing calculations for the beam are displayed, and you can check
these for each of the beam’s spans.

Step 1. Use the Check Member command to perform check designs on some of the beams that are
already passing their designs.

25.2 Design Member

The Design Member command also works for beams in the exact same way as it does for columns.

To perform an automatic design for a single beam, simply right click over a beam and choose Design
Member.  All spans of that individual beam will be designed based on the analysis results for that
beam, and the reinforcement selected will then be copied to all other beams in the same design
group.

Check Design will be completed on these members, and their design calculations and statuses will
be updated immediately.

As with columns, if you use the Design Member command on a beam that isn’t a critical beam in that
design group, you may find some beams that had passed will suddenly fail.

Step 1. Locate beam 1B4 in the model from design group CRB6.
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Step 2. Use the Design Member command to design beam 1B4 – some other beams should now
have warnings against them.

Step 3. Use the Design Group command in the Groups tab to re-design group CRB6.

25.3 Design…

If you’d like to check a beam for specific reinforcement, or you just want to adjust the reinforcement
automatically selected by TSD to see how it affects the design, you can use the Interactive Design
capabilities in a similar way to columns and walls.

To do this, you simply right click over a beam and choose Design….

25.3.1 Interactive Design

Once selected, the Design… option will first perform a Check Design on the beam in question, and
then allow you to edit the existing rebar for each span, based on that element’s analysis results.

For beams, you can adjust the top and bottom longitudinal bar sizes and their quantity, the side bar
size and quantity (if required), and the link bar size, number of legs and spacing.

This is done by selecting the appropriate span in the left hand pane, then selecting the required tab
on the right and adjusting the various settings.

As soon as any of these settings are changed, the sketch, design statuses and results are instantly
updated and displayed.  You can also then click the Check button on the right hand side of this
window to perform a check design of the edited reinforcement and view the full design calculations,
as discussed earlier.
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Step 1. Open the Interactive Beam Design window for a few different beams in the model, except
the ones with warnings.

Step 2. Review their designs, and try adjusting the reinforcement placed in some of them to see how
they affect their design status.

25.3.2 Detail Drawing

The Detail Drawing button in the Interactive Beam Design window allows you to  quickly  view a
detailed drawing of the beam.  You can make adjustments to the design of the element, and then
instantly create a detailed drawing of it, using whichever CAD program you have installed on your
machine.

The detailed drawing generated by this method will include an elevation drawing of all spans making
up the whole beam, section drawings for each span and support regions for each beam span, and a
quantities table as default.

As with the columns and walls, though you’re more likely to generate detail  drawings of multiple
beams at once using other functionality in the program, this feature can still be very useful in
understanding the design of the element in question.  The production of detail drawings will be
discussed further later in this course.

Step 3. Generate and review the Detail Drawing for some beams.

25.3.3 Correcting the Warnings

As you will have seen, some beams in the model have some warnings and are shaded amber when
viewing the Results View - Design Status.

Opening the Design… window for any of these beams shows green ticks for all of the design results
displayed, which suggests this is potentially a detailing issue.

Therefore, the Check window needs to be opened to view all of the calculations to see exactly what
the issue is.

Step 4. Open the Interactive Beam Design window for beam 4B3.
Step 5. Click the Check button to view the calculations.



25 Interactive Design of RC Beams 184 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

As seen above, the issue here is with the Concrete Cover checks.  The automatic design has selected
bars that are sufficient for the design checks but due to the selection of 32mm bars, the nominal
cover specified in the beam design is not quite sufficient to meet the code criteria.

There are various different ways of correcting this issue, such as increasing the beam nominal cover,
adjusting the section sizes or reducing the forces in the beam by editing the model.

However, the easiest, and probably most sensible approach here, would be to reduce the bar size
being used in the beam design.  For a model of this size with these sorts of element sections, it would
be quite unlikely that 32mm bars would be used in reality.

Step 6. Use the Interactive Beam Design window to adjust the reinforcement provided for beam
4B3 so that it passes both the design and detailing checks.

Alternatively,  you  could  try  to  set  the Maximum Longitudinal Bar Size for beams in the Design
Options to a smaller bar size (say 25mm), and then re-run the Design Concrete (Static) process again
to make sure no beams in the model use 32mm bar size.

25.3.4 Updating the Design Groups

As with the Design Member command,  when you click  OK to  confirm the interactive  design of  a
beam, the rebar selected in the new design is applied to all of the beams in the same design group.

A Check Design is then performed on them and their design calculations and statuses will be instantly
updated.  To make this a more productive process, make sure that you interactively design the critical
beam(s) from the Design Group by checking the Groups tree – the critical beam within a group is
signified with a red exclamation mark.

Step 7. Click OK to confirm the beam design and ensure that all beams in the same group now pass.
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26 RC Slab Design

As seen earlier, all frame elements are designed in one go as part of the Design Concrete (Static)
process.  However, slabs are designed using a separate, slightly more manual procedure, which will
be covered in detail in this example.

Step 1. Open the model TSD Concrete Design Fundamentals Model 4 - Slab Design.tsmd.

26.1 Introduction to Slab Design

To design the concrete slabs in a model, whether they’re part of a Flat Slab or a Beam and Slab
structure, there are a number of steps required to get as simple yet economical reinforcement
arrangement as possible.

When slabs are initially created, they have several
properties relating to their reinforcement, known as their
background reinforcement.   When  the  slab  is  then
designed, this reinforcement will be automatically selected
based on all of the analysis results calculated anywhere
within the slabs, and then placed throughout the whole
slab panel.

Designing the background reinforcement in this way, to
resist all forces in the slabs, would result in excessive
reinforcement provisions, as the higher peak forces, and
hence the higher reinforcement requirements in the slabs,
normally only occur in isolated, local positions, such as
near beams or at the corners of core wall areas.

Therefore, a variety of Patches need to be inserted into the
model in these local areas so that the background
reinforcement placed throughout the whole slab panels
can be kept down, and additional reinforcement can be
placed in the patch positions.

There’s a variety of different Patch types available, depending on the location of where the patch is
to  be  placed,  such  as  over  columns,  walls  beams  or  in  the  middle  of  slab  panels.   The  patches
essentially just contain a number of strips running in both directions, some of which are set to design
for the average design forces across their widths, and others simply gather a maximum value from
across their widths.

Once the main slab design is completed, Punching Shear Checks can then also be added to specific
columns and walls in a similar manner to adding patches, to see whether any additional shear
reinforcement is required in these locations.

The model used for this exercise has some floors which are flat slab and others which are of beam
and slab construction.

Step 1. Select any slab in the model and review its Reinforcement in the Properties window.
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26.1.1 Overall Slab Design Procedure

Below is a brief overall view of the full slab design procedure.  These points will be discussed in more
detail throughout the rest of this example.

· Insert the patches in the appropriate locations

· Design the slab panels to select the background reinforcement for the whole slab panels to
resist the forces in the slab areas not covered by patches

· Review and optimise the slab panel designs by rationalising the selected steel

· Design the patches to calculate the additional reinforcement required in the areas of slab
covered by the slab patches

· Review and optimise the patch designs by rationalising the selected steel

26.2 Checking the Background Reinforcement with No Patches

As an initial test, all slabs in the whole model can be designed without having any patches placed in
the model.  This is done by clicking the Design Slabs command on the Design tab.  This means the
background reinforcement will be selected on every level so that each slab panel in the model will
have sufficient reinforcement placed in it to be able to resist any of the moments anywhere within
that panel.

Step 1. Go to the St.2 (Transfer Level) 2D view, click the Design Slabs command on the Design tab.

Once the design of the slabs is complete, the scene view should automatically switch to the Review
View mode and show the all slabs passing.
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However, using the Slab Reinforcement command on the Review tab, you can see the reinforcement
selected, based on the options selected in the Properties window, which could be seen as a little
excessive.

Step 2. Use the Slab Reinforcement command and the Properties window to see the reinforcement
that has been automatically selected and placed throughout the slab panels.

26.3 Types and Applications of Patches

As the background reinforcement selected is too high, Patches need to be inserted into the areas
where higher reinforcement are required.  There’s a variety of different Patch types available,
depending on the location of where the patch is to be placed, and they’re found on the Design tab.
They include:

· Patch Column – placed on columns in flat slab models, to deal with local peak moments

· Patch Beam – placed along beams, usually to deal with hogging moments

· Patch Wall – placed along walls, with options associated with the position and span of the
wall

· Patch Panel – placed in the middle of slab spans to deal with local peak moments

Patches contain a number of strips, some of which are set to design for the average design forces
across their widths, and others simply gather a maximum value.

The patches also have a variety of properties allowing you to control options like the patch size, strip
widths, bar sizes and their spacing.  It is important to make sure the patch sizes are appropriate for
the model.

The easiest way to do this is to insert the patches whilst viewing the results contours to ensure the
peak forces are contained within the patch dimensions.

You should also ensure that both the slab panel and patch minimum bar spacing are sensible before
attempting the design.

Patches are inserted into the model by first selecting the patch command you want to use, then by
either left clicking on an appropriate element, or by dragging a window around multiple elements.

Step 1. Go to the St.1 (1) 2D view and set to the Results View mode.
Step 2. Select the Total Load combination, choose the FE Chasedown Results Type from the Results

tab and review the slab design moment and area of steel requirement contours.
Step 3. Switch to the Design tab.

26.3.1 Wall Patches

There are different wall patches available, depending on where the walls are located and how they
intersect.  The different types can be selected using the Create Mode option in the Properties
window once the Patch Wall command has been activated.

In this example, the Single Patch Along Wall option will be used for the two opposing horizontal
walls, which are inserted by either left clicking on the individual walls, or by dragging a box around
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them.  The remaining wall will use the Internal Patch option, which is inserted by left clicking on the
start and end points along the wall that isn’t covered by the other already inserted wall patches.

Step 1. Select the Patch Wall command on the Design tab.
Step 2. Set the Patch Width to be 2m.
Step 3. Insert the patches on the 3 walls in the model, using the appropriate Create Mode settings.

26.3.2 Beam Patches

The rest of the patches inserted on St.1 will be Beam Patches. Column Patches are not required as
all columns on this floor are connected to beams, so they will be covered by the beam patches.

Step 1. Select the Patch Beam command on the Design tab.
Step 2. Ensure the Patch Width is set as 2m and then drag a window around the whole floor to

insert all of the Beam Patches at once.
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26.4 Design the Slab Panels

Now that all patches are inserted into the floor, the slab panels can be designed by clicking the Design
Slabs command on the Design tab.  The auto design selects the background reinforcement for the
slab panels, ignoring the forces that develop within the slab patch areas, but the background
reinforcement is placed throughout the whole slab panel.  This process still applies to the slabs on
all levels.

Step 1. Click the Design Slabs command on the Design tab.
Step 2. Use the Review View and the Review tab to view the design Status of the slab panels.

The reinforcement selected for the panels now should be less than before the patches were added.

26.5 Review and Rationalise the Panel Design

Once the slab panels have been designed, you can view the selected reinforcement using the Slab
Reinforcement command on the Review tab when in the Review View.  The Slab setting in the
Properties window should be set to Panel, and you can then review the reinforcement placed in the
panels for the top and bottom of the slab, and in the X and Y directions.

The Apply property allows you to apply the reinforcement selected for one panel into other panels,
simply by selecting the reinforcement you want to apply to a panel in the Properties window, then
left clicking on the panel in the view.  This allows you to rationalise the background reinforcement
for all slab panels.

Once applied, a Check Design is performed on the slabs to ensure they still work.
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Step 1. Review and rationalise the top and bottom reinforcement selected for both the X and Y
directions.

26.6 Design the Slab Patches

Now that the panels are appropriately designed, the patches can also be designed by clicking the
Design Patches command on the Design tab.  This auto design process considers the reinforcement
that has already been provided in the whole slab panels, and selects the additional reinforcement
required for within the patch areas.  Once complete, this should mean the patch areas have sufficient
total reinforcement to resist the forces that are acting within them.

Step 1. Click the Design Patches command on the Design tab.
Step 2. Use the Review View and the Review tab to view the design Status of the slab patches.

26.7 Review and Rationalise the Patch Design

As with the slab panels, once the patches have been designed, you can view the selected
reinforcement by using the Slab Reinforcement command on the Review tab when in the Review
View.  The Slab setting in the Properties window should be set to Patch first, and you can then review
the reinforcement placed in the patches, much like you could for the panels.

The Apply property allows you to apply the reinforcement selected for one patch into other patches,
simply by selecting the reinforcement you want to apply to a panel in the Properties window, then
left  clicking  on  the  patch  in  the  view.   This  allows  you  to  rationalise  the  additional  patch
reinforcement to get a simple yet economic arrangement.
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Once applied, a Check Design is  performed  on  the  slabs  to  ensure  they  still  work  for  the  new
arrangement.

Step 1. Review and rationalise the additional patch reinforcement selected for both the X and Y
directions – this will typically only apply to the top reinforcement.

Once this stage is complete, the slab is completely designed for the first storey St.1.  However, as
St.1 is a unique storey, no patches exist on any other levels, so a similar process would need to be
completed for all other unique levels, or levels that have been used as the Source Storey in the
Construction Levels window.  At present, the slabs on all other storeys are designed with no patches,
so their current background reinforcement could be considered excessive.

26.8 Flat Slab Design

The process for designing a Flat Slab structure or floor is exactly the same as designing a beam and
slab model – the only real difference is the type of patches used.

Step 1. Switch to St.4 (4) 2D view, set to the Review View mode.
Step 2. Select the Slab Design Status command on the Review tab.

As you should see, this level is a flat slab.  The Slab Design Status should show that the slab passes
the design due to the Design Slabs process having been completed earlier.  However, as there are
no patches inserted on this level, this means the background reinforcement has been selected to
resist all forces acting anywhere within the slab panels.

Using the Slab Reinforcement command on the Review tab, you should be able to see that the
selected top reinforcement is quite high in some slab panels due to the higher hogging moments
over the columns and at the corners of the core wall.
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Therefore, some patches need to be inserted into this floor to help reduce this background
reinforcement in a similar manner to the beam and slab level.

Step 3. Review the currently selected background reinforcement.
Step 4. Go to the Results View mode, select the Total Load combination, choose the FE Chasedown

Results Type from the Results tab and review the slab design moment and area of steel
requirement contours.

Step 5. Switch to the Design tab.

26.8.1 Wall Patches

The Wall Patches can be inserted into this floor following the same method as discussed earlier, only
this time, the Internal with End Patches option will be used for the Create Mode for  the two
horizontal walls.  These are inserted by either left clicking on the individual walls, or by dragging a
box around the walls instead.

This is because on the other floor, beams connected into the
walls,  so  the  beam  patches  helped  to  cover  the  forces  on  the
corners of the core wall.  As this is a flat slab level, the use of wall
end patches should ensure that all of the peak forces at the corner
positions are covered by the wall patches.

The remaining wall will use the Internal Patch option, the same
as on St.1.

Step 1. Select the Patch Wall command on the Design tab.
Step 2. Set the Patch Width to be 2m.
Step 3. Insert the patches on the 3 walls in the model, using the appropriate Create Mode settings.
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26.8.2 Column Patches

The rest of the patches on this storey will be Column Patches. These column patches can be inserted
into the floor by either left clicking on individual columns, or by dragging a window around multiple
columns.

As with the beam and wall patches, their dimensions can be adjusted in the Properties window to
ensure all of the higher peak force contours are contained within the column patch.

For  models  such  as  this  example,  you  will  likely  find  larger  column  patches  are  required  for  the
internal column positions, where the moments in the slabs will be higher.

Step 4. Try inserting some column patches (3m x 3m) into the floor, adjusting their dimensions as
required.

26.8.3 Completing the Design of the Floor

To complete the design of this floor, simply follow the same process as for St.1 level:

Step 5. Design the Slab Panels to select the background reinforcement for the whole slab panels to
resist the forces in the slab areas not covered by patches.

Step 6. Review and optimise the panel designs by rationalising the selected steel.
Step 7. Design the Patches to calculate the additional reinforcement required in the areas of slab

covered by the slab patches.
Step 8. Review and optimise the patch designs by rationalising the selected steel.
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As St.3 is a duplicate of St.4, you should find that this floor has also been designed.

When duplicate levels are modelled and the slabs are designed, it works in a similar way to Design
Groups.  When the Design Slabs and the Design Patches commands are completed, the panels and
patches on the Source floor are designed, and then their selected reinforcement is then copied to
its duplicates.  A check design is then completed on the duplicate floors and their design status is
updated.  This means that you may find that some panels and/or patches fail on the duplicate levels.

To rectify this, you simply need an auto design to be completed on the level with the failures.  This
can be done by either selecting the failing element, right clicking and choosing Design Member, or
by right clicking anywhere in the view and choosing Design Slabs or Design Patches.

Once one of these design processes have been completed, you can then review the full design
calculations for the slabs in question.

26.9 Punching Shear Checks

The final step in the flat slab design process is to complete the Punching Shear Checks.

This must be completed after the main slab reinforcement has been designed so that it can be
correctly considered when calculating if any additional shear reinforcement is required.

Punching checks are inserted by clicking the Add Check command on the Design tab.   They’re
inserted in a similar method to inserting column patches – you can either left click on individual
columns, or you can drag a window around multiple elements.

Step 1. Insert a few punching shear checks in different locations on St.4 using the Add Check
command.
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Once you have inserted the punching shear checks, you can use the Punch Check Position command
on the Review tab to make sure TSD has specified the correct position settings for each inserted
check.

If you want to change the position setting for a particular check, simply left click on the check in the
view and it will change to the next setting in the list.

Keep left clicking on the check to cycle through the options until the one you want to use is selected.
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Once you’re happy with the position settings of the checks, click the Check Punching Shear command
on the Design tab to complete the checks.

The checks will be highlighted in Green (Pass) or Red (Fail), depending on whether the checks passes
or fails.

To view the punching check calculations, simply right click over one of the punching checks and
choose the option Check Punching.

Step 2. Click the Check Punching Shear command on the Design tab.
Step 3. Right click over one of the punching checks to view the calculation.
Step 4. Save the model.
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27 RC Members Detail Drawings

As seen earlier, Detail Drawings of individual frame elements can be created via the Interactive
Design windows.  However, there are a variety of other detail drawing options available on the Draw
tab.

27.1 Drawing Settings

As with the Analysis and Design settings, it is important to review the Drawing Settings before
generating any detail drawings.  This is done by clicking the Edit... command on the Draw tab.

Step 1. Go onto the Draw tab and click the Edit... command.

27.1.1 Layer Configurations

Selecting the Layer Configurations option on the left hand side of the Model Settings window allows
you to control what information is included in each of the different types of drawings that can be
created.

· Select a layer configuration and choose a Drawing Variant.

· Select on an Available Configuration from the list its details into the Active Configuration
area of the window.

· Active Configuration displays the Name of that type and the various Layers that  will  be
contained in the drawing when it’s created.  Using the tick boxes, you can add or remove
layers from the Active Configuration.

Step 1. Review the various Drawing Varients available.
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27.1.2 Layer Styles

Once you have specified which layers are displayed for each detail drawing type, you can then control
how those layers are displayed by adjusting the Layer Styles.

Similar to the Types page of settings, the Layer Styles page allows you to choose a Drawing Variant
and Available Styles.  Once the Active Style is selected, you can then edit the various settings for the
Layers to suit your needs.

These settings include the Name of the layer, the Colour, the Line Type, the Font type and the Font
Size.

Step 2. Review the various Layer Styles available.

27.1.3 Options

As well as the Types and Layer Styles, there are various other Options also available for the main
concrete detail drawings.  These can act like filters for individual layers.

For example, you can choose to include the Labels layer in the Types page of settings for a particular
type of drawing, but you can use the Options to include or exclude specific labels that all combine to
make up that single layer.

Step 3. Review the various Options available, then click OK to confirm all settings.

27.1.4 Detailing Groups

As discussed earlier, all concrete beams and columns are automatically placed into Design Groups
to allow for a quick and efficient design process.  At the same time, corresponding Detailing Groups
are also automatically created with the same names and the same members inside them, which
allows for a refined and efficient detailing process.
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Although all the elements inside a design group are similar enough to allow them to have identical
designs, there could be variations in the other elements surrounding and connecting to the members
in that group, which would result in differences in the detail drawings created for each of the group
members.

Therefore, within the Detailing Groups, there are sub-groups
containing the elements with the same detailing arrangements.

For example, you could have a design group containing 10 beams,
which are all designed identically as they have the same section size,
number of spans, span lengths, etc.  However, in the corresponding
Detailing Group, there could be two sub-groups – one for the 5
beams supporting a 200mm thick slab, and the other for the 5 beams
supporting 300mm thick slabs.

Step 4. Review the Detailing Groups in the Groups tab under
Project Workspace.

27.2 Detail Drawings of Individual Elements

Detail Drawings of all individual frame elements (i.e. columns, walls and beams) can be created via
the Interactive Design windows.  These same detail drawings can also be generated by right-clicking
over the element in a view and choosing Generate Detailing Drawing….

Once selected, the DXF Export Preferences window will display the file name and where it will be
saved, which can be changed by unticking “Use automatic file name”.

The Layer Configuration and Layer Style should be automatically selected based on the type of
member you’re creating the drawing for, and the corresponding Drawing Variant.

You can also adjust the Scale of the drawing, as well as the Minimum Text Blocking Spacing.

Clicking OK will create the drawing and display it using an appropriate CAD program that you have
installed.

Step 1. Try generating some individual member detailing drawings.



27 RC Members Detail Drawings 200 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

27.3 Schedules

As well as creating detail drawings for individual members, Schedules can also be created for
columns, walls and beams by clicking the appropriate schedule commands on the Draw tab.

Column and Wall Schedules can be created when in any view of the model, but Beam Schedules can
only be created when viewing a plan view.

· The Column Schedule -  allows you to select which Column Detailing Groups you want to
included.

· The Wall Schedule - allows you to select which walls to be included.

· The Beam Schedule - all beam detailing groups are included for the currently active plan
view.

Once confirmed, a DXF Export Preferences window will open, similar to the Generate Detailing
Drawing command.

Clicking OK will create the schedule and display it using an appropriate CAD program that you have
installed.

Once the schedule is generated, various information will be displayed.

· The Column and Wall Schedules will display various Sections of the different members
selected to help display the longitudinal bars and links, along with a Quantity Table.

· The Beam Schedule will provide information on the reinforcement provided in the beams,
along with bar bending details.

Step 1. Try creating one of each of the available Schedules.
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27.4 Slab Detail Drawings

The Drawings group on the Draw tab provides options to create General Arrangements and Slab
Detailing.  These commands are only available when a 2D plan view is active.

27.4.1 General Arrangements

The General Arrangement command will create either a Plan, Section or Elevation of the active plan
view or frame view.  These typically include information such as Detailing Group labels, element
section sizes and gridlines, and simply show the general layout information for the plan or frame
view in question.

As with the other detail drawings and schedules, there are various options and settings relating to
the General Arrangements in the Types, Layer Styles and Options areas of the Drawings Settings.

After clicking General Arrangement command,  you  will  see  the  same DXF Export Preferences
window as mentioned earlier, with the Type and Layer Style options, and clicking OK will generate
the drawing.

Step 1. Try creating some General Arrangements of some plan and frame views

27.4.2 Slab Detailing

The Slab Detailing command will also create a Plan drawing of the active plan view. They will provide
information on the reinforcement provided in the slab panels and patches, along with the patches
themselves and dimensions.  Therefore, the slab design process must be completed as required
before generating the Slab Detailing drawings.

There are also various options and settings relating to the Slab Detailing in the Layer Configurations,
Layer Styles and Options areas of the Drawings Settings.

After clicking Slab Detailing command, you will  see the same DXF Export Preferences window as
mentioned earlier, along with the Layer Configuration and Layer Style options.
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The default Layer Configuration option in this window is Slab Detail (All) and will include information
on all top and bottom reinforcement.  Depending on your model, this could results in a cluttered
drawing, so it would likely be more useful to select either the Slab Detail (Top Reinforcement) or
Slab Detail (Bottom Reinforcement) options.  Clicking OK to  this  window  will  generate  the  Slab
Detailing drawing.

Step 2. Try creating some Slab Detailing drawings for the floors that have already been designed
in this model.

Step 3. Try using some of the different Layer Configuration options to see the differences between
the drawings that are created.

27.5 Drawing Management

If you’ll want to generate detail drawings of multiple elements in one go, you can use the Drawing
Management command on the Draw tab.  In this window, the first thing to do is select the Drawing
Variant.

27.5.1 Concrete Member Detailing

The Drawing Variant Concrete Beam Detail and Concrete Column Detail can be used to generate
detail drawings of multiple frame elements at once.  The easiest way to create these drawings is to
use the Generate command.

This will populate the Available Drawings list with some standard drawings and their content.

The first drawing will be for the Typical elements in the model, which will contain multiple drawings,
one for each of the Detailing Groups that contain more than one element.
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There will also be some additional Available Drawings which will contain drawings for any remaining
elements that are in Detailing Groups on their own.

Alternatively, you can generate completely custom drawings by clicking the Add button.

You can check the information contained in each of these drawings by selecting them in the Available
Drawings list, then clicking the Content… button.

This will open the Drawing Content window, listing any Available Members that could be included
on the left hand side, and any elements or detailing groups already contained in the Drawing on the
right.  You can then control this content by left-clicking and dragging elements or groups from one
list to the other.  Once you’re satisfied with the content, clicking OK button will confirm it.

The Layout… button in the Drawing Management window will allow you to control the layout of
the elements contained within the drawing.
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To view a drawing, select it in the Available Drawings list and then click the View Drawing… button.

The same DXF Export Preferences window mentioned earlier will then appear, including the same
Type and Layer Style options.

Clicking the OK button will then create the drawing and display it in an appropriate CAD program.

Step 1. Try generating the standard Available Drawings for the Beams, Columns and Walls and
review their content and layout settings.

Step 2. Use the View Drawing command to create the drawings.

In the Drawing Management window, the Selected Drawing area displays information about the
currently selected Available Drawing.  This will show the current Status of the drawing, how many
Items the drawing contains, and gives you the ability to define the Name for the drawing.
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If you decide to make amendments to the drawings you’ve created but want to keep the originals,
or  if  you just  want  to  make different  versions  of  the same drawings,  you can click  on the Create
Revision… button.

This will open the Create Drawing Revision window, which will provide similar options to the DXF
Export Preferences window.  It also allows you to adjust the name of the drawing file that will be
created, where it will be saved and define the Next Revision Name, which automatically adds extra
text to the automatic file name.  There is also an option to add Notes to the revision to help clarify
the differences between the existing revisions.

To  view  the  revision  history  of  a  drawing,  simply  click  the History… button in the Drawing
Management window.

Step 3. Try adding and creating a custom Available Drawing.
Step 4. Try making some revisions and view the revision history.

27.5.2 Other Drawing Management Options

The other Drawing Variants available in the Drawing Management window do not have a Generate
option to create standard Available Drawings.  Therefore, the only way to create the drawings for
these options is to use the Add button.  Other available variants are:

Once the Add button has been clicked, the drawing will exist, but it will contain no items.

Therefore, you need to review the Drawing Content window  to  add  the  required  items  to  it,  as
discussed earlier.  You can create a number of different Available Drawings for each Drawing Variant,
and all other commands in this window can be used in the same manner as for the automatically
generated drawings.
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Step 5. Try creating some custom drawings for the other Drawing Variants.
§ General Arrangement plan views of St.2 and St.5
§ General Arrangement frame views of Frame 2 and Frame E

27.5.3 Schedule Management

You can use Schedule Management to create custom schedules for columns, walls and beams.

You can create a number of different Available Drawings for each Drawing Variant, and all other
commands in this window can be used in the same manner as Drawing Management.

Step 6. Try adding the standard Available Drawings for  the Concrete Beam, Column and Wall
Schedules.
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28 RC Members Design Reports

Once members have been designed, there are a variety of different Design Reports that can be
generated in TSD.  These can be in-depth or summaries, and for either individual frame elements,
multiple elements or the model as a whole.  The majority of these reports can be generated from
the Report tab or from the right-click menu.

28.1 Individual Member Design Reports

To quickly generate a report for an individual frame element, you can simply right-click over the
element in question in an appropriate scene view, and then choose Report for Member.

This works the same way for columns, walls and beams.

 As default, the report will be a summary report, and will typically include a sketch and a brief
overview of the design status and reinforcement provided.

Step 1. Try using the Report for Member command for a beam, a column and a wall.
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28.1.1 Report Content

The content of the report generated using the Report for Member command is dictated by the
Member Report… command, found on the Report tab.

To change the content to be included in the report, you should first select the appropriate Member
Type option in the top left corner.  You will then be able to see the Available Styles for that particular
member report.  Selecting one of the Available Styles in this list will then display the content of that
report in the Report Structure list.

You can then add or remove information from the selected report style by clicking and dragging items
between the Report Structure list and the Chapters and Options list.

As you can see above, there could be numerous Available Styles for particular member reports.  The
default is usually the Summary version of the report.

If you want a more detailed design report when you select the Report for Member command, you
can select a different report style, and then click the Active button.

The Active  report  style  is  the one used to  generate the report.   If  you have already generated a
particular report, then change the Active style, the existing report should automatically update to
include the updated style content.

Once listed in the Report Structure list, you can also control the level of information displayed in the
report by right clicking over the items.

There will be options to make an item Active or not (i.e. displayed in the report), you can Remove
Items from the report altogether, and you could change the Settings for individual items – these
setting could include the type and style of drawing to be included or the level of design calculations
displayed.

Step 1. Click the Member Report… command on the Report tab.
Step 2. Make sure Summary styles are Active for the Concrete Wall and Concrete Beam options,

and the Full Design report style is Active for the Concrete Column option.
Step 3. For the Concrete Column option, right click over Design Calculations in the Report Structure

list and choose Settings.
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Step 4. Make sure the Design Calculations Level is set to 1, then click OK to confirm these settings
– this will increase the amount of detail shown in the design calculations in the report.

Step 5. View the updated existing column member report to view the changes in content levels.

28.2 Model Reports

You can also create reports for multiple elements at once using one of the standard Model Reports.

To generate a Model Report, simply choose an option from the Select drop down list on the Report
tab.  Once a report has been selected from this list, clicking the Show Report command will then
generate the report and allow you to view its contents.

The report Member Design Calcs will allow you to view the same design reports generated earlier
using the Report for Member option, but for all elements in the model in a single report.

The amount of output given for each individual member in this report is controlled by the same
Member Report window also discussed earlier.

The Model Report command can also be used to control which element types are included in the
report, and works in a very similar manner to the Model Report window.

Step 1. Select the Member Design Calcs option in the Select drop down list.
Step 2. Review the Model Report Contents window to make sure only reinforced concrete beams,

columns and walls are included, then click OK to confirm, as shown below.
Step 3. Click Show Report command to generate the report, then review the content.

As you can see, creating a Model Report and editing the content could result in very large reports
being generated, especially if you have a large model with lots of members.

Therefore, the Filters options on the Report tab can be very useful to make sure only key required
information is contained in the reports generated.
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For example, clicking the Members Filters button on the Report tab allows you to Add a filter to the
list of available filters.  Once a filter is added, all frame members – i.e. beams and columns – will be
listed on the right hand side of the window, allowing you to tick the members you want to include in
the report.

To do the same for walls, you need to use the Frames Filter.

Once the filter is set up, you then go back into the Model Report window, right click over the
appropriate entry in the Report Structure list and choose Model Filter > Selected Members.

The report will then automatically update after clicking OK.

Step 4. Add a Members Filter to the newly created Member Design Calcs report.
Step 5. Reduce the size of the report by only including a few of the beams and columns, then click

OK, apply the filter and update the existing report.

28.3 Other Report Options

Although we have only discussed the Design Member Calcs Model Report, there are various others
that are available which could also be of use, and their content and layout can be controlled in exactly
the same way as already discussed.  Another useful design report is the Building Design option, which
essentially shows a design summary for all frame elements, as well as the slab panels, patches and
punching checks.

As with any report generated in TSD, you can use the various commands on the Report tab to adjust
how the report is displayed in the program, edit the layout and labels used in the Header and Footer,
navigate through the reports, and Export the reports into various other programs and formats.
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29 Design Groups

Step 1. Open the model TSD Concrete Design Fundamentals Model 2 – Design Groups.tsmd.

29.1 How are Design Groups Formed?

To allow for a quick and efficient design process, all concrete beams and columns are by defaults,
automatically placed into Design Groups.

Design Groups have no specific engineering data associated
with them and are simply a unique name for collection of
similar frame elements.

Various criteria are used to determine which group a
particular element will be automatically placed in, but they
can only belong to a single design group.

For example, if you have a number of columns in a model,
each with the same number of stacks, similar stack lengths,
the same concrete and reinforcement material properties,
and the same section sizes, rotations and alignments in the
corresponding stacks, then they will likely all be placed in
the same group.

If any of these options vary between the columns, then they will be placed in multiple groups.

The Design Groups are formed as you build up the model, and can be viewed using the Groups tab
in the Project Workspace.  This window also allows you to do a variety of other things, including
editing the groups and re-grouping the elements, which will be discussed shortly.

Note that concrete walls are designed independently from each other and do not use design groups.

Step 1. Go to the Groups tab in the Project Workspace and view the Design Groups for this model.

29.2 The Design Procedure for a Design Group

When a design group is designed, either as part of the Design Concrete (All) process or when a single
group is designed, there are a series of steps that are completed:

· One element in the design group is arbitrarily selected, and will have a full design completed
on it for all of the results generated, by all analyses that have been undertaken.

· The reinforcement selected and placed in this first element will then also be applied to all
other elements in that design group, so that they all have the same reinforcement
arrangement.

· One of these other elements will then have a check design completed on it, to make sure the
reinforcement is sufficient for it.

· If the reinforcement is sufficient, then it will move on to the next column and check the
reinforcement for that element, and so on.
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· If an element requires more reinforcement, then it will be increased and then the updated
reinforcement will be applied to all other elements in the group.

· The process will then continue until all elements in the group have all been checked, resulting
in them all having the same reinforcement arrangement.

· Once all elements have been designed in the group, a final check procedure will work out
the utilisation ratios for all elements in the group to determine the ‘critical’ element, and an
average utilisation ratio will be calculated for the purposes of reviewing group efficiency.

29.3 Working with Design Groups

As mentioned earlier, when the design of all frame elements is completed on a model, it will design
all  groups  in  the  model.   For  a  lot  of  the  time,  especially  with  fairly  regular  models,  these
automatically-created design groups are going to be more than sufficient, and will not need to be
changed.  However, the Groups tab has a number of features that allow you to interrogate, modify
and re-design specific groups in the model.

29.3.1 Interrogating the Design Groups

Expanding the entries in the Groups tab allows you to see a full list of all the design groups that have
been generated by the program, and the elements that make up each group.

If you want to locate all the members that are in a particular design group, ensure you’re viewing an
appropriate scene view, usually the Structure 3D view, then simply right click over the Design Group
name in the Groups tab, and choose Select in visible views.



29 Design Groups 213 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

The same option is also available for locating the individual elements listed underneath the Design
Group name.

The Critical element(s) in the Design Group are highlighted in the Groups tab with a red exclamation
mark (!), so you can use the above command to find all elements in a particular Design Group and
then the critical element from that group.

Note that there may be more than one critical element in a group, as there will be one marked for
the critical shear and one for the critical bending.

Step 1. Set the Structure 3D to be the active scene view.
Step 2. Try selecting some different beam and column design groups and individual elements from

those groups in the model.

29.3.2 Renaming Design Groups

When design groups are generated as you build up the model, they are automatically assigned group
names.  For beams, these will be CRB followed by a number, and for columns, it will be CRC and then
a number.

To give them more meaningful names, you can manually re-name groups by right clicking over the
Design Group name in the Groups tab, and choose Rename Group.   You can then type in a new
name, and press Enter to confirm.  This will also update the related Detailing Groups names as well.

Step 3. Try selecting some design groups and then use the Rename Group command to assign more
meaningful names to them.

29.3.3 Splitting Design Groups

Although the automatically formed design groups will usually be perfectly suitable for the majority
of the time, you may occasionally find a group made up of dimensionally very similar elements, but
which have quite different forces acting on them.  This could result in some of these elements having
more reinforcement placed in them than they actually need for the design.

In this case, you may decide to use the Split Group command.

Doing this will place all members from the group being split into their own separate groups,
effectively allowing them to be designed as ungrouped.

Groups are split by right clicking over the Design Group name in
the Groups tab, and choosing Split Group.

Step 4. Try splitting the column design group CRC13 to form two
new groups containing only one element each.



29 Design Groups 214 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

29.3.4 Adding and Modifying Existing Groups

For  similar  reasons  to  splitting  groups,  you  may  decide  to  create  a  new  group  and  then  move
elements from the automatically-generated groups into the new group.

To  add  a  new  group,  simply  right  click  over  one  of  the
Design Group sub-headings, either Concrete Reinforced
Beams or Concrete Reinforced Columns depending on
the type of group you want to create, and then choose
Add Group.  This will create a new, empty design group
inside that folder, as well as a corresponding Detailing
Group.

To add elements to that new group, simply click and drag
the element name from inside one group onto the new
group  folder.   TSD  will  prevent  you  from  moving  an
element into a group that contains elements that can’t be
grouped together, such as ones with different section
sizes.

In this model, the Concrete Reinforced Column design group CRC4 contains a number of elements.
The designs for these elements are obviously the same, but column C26 has some large loads applied
on and near it, resulting in much higher moments in this element, which in turn is dominating the
bending design for the whole group.  Therefore, C26 could be moved into a new, separate group to
be designed independently from the other elements.

Step 1. Make sure the design results for the whole model are up to date.
Step 2. Right click on C26 and choose Check Member to see an overview of the reinforcement

selected for all elements in the group, and do the same for another member in this group to
confirm.

Step 3. Use the Add Group command to create a new Concrete Reinforced Column design group.
Step 4. Click and drag column C26 from group CRC4 into the newly created group.

29.3.5 Designing Individual Groups

Instead of repeating the full analysis and design process again, individual design groups can be
designed to take into account their updated contents.  This is done by right clicking over the Design
Group name and choosing Design Group.  You can then check the designs of the members again to
see the differences.

Step 5. Use the Design Group command to re-design CRC4 and the newly created group.
Step 6. Use the Check Member command to compare the designs between the two.
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29.3.6 Re-Group All Model Members

If you have edited the Design Groups in a model and want to go back to the original groups created
by TSD, you can click the Re-Group ALL Model Members button, located in the top left corner of the
Groups window.

If  you  click  this  button  by  mistake,  the Undo command  will  revert  back  to  your
edited groups.
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30 Analysis and Design of Steel Structure

In this session we will take a detailed look at the analysis and design of a steel structure.

Step 1. Open the example model file 1_Design_Start.tsmd.

30.1 Combination Classes

In a typical model there can be many different combinations. These could be classified as
construction stage, gravity, lateral, seismic, seismic RSA or vibration.

· A gravity combination is a combination that contains only gravity loads, whereas a lateral
combination is one that include lateral effects such as equivalent horizontal forces (for lack
of fit) and/or wind loading.

Combinations are classified in this manner to streamline the subsequent member
design process.

Step 2. Review the combination classes via the Combination command in the Load tab.

30.2 Properties

The properties to be assigned to a new entity such as a steel column, steel beam or steel brace are
displayed in the Properties window prior to creating the entity. These properties can also be
reviewed and amended at a later date for selected entities via the Properties window.

Two important design properties that streamline each individual member design process are the
Gravity only and Autodesign options.
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30.2.1 Gravity only

The Gravity only option has two settings;

· Ticked - designed for gravity combinations only.

· Unticked - designed for both gravity and lateral combinations.

Two examples are provided below to understand why this setting might be checked.

Non-composite or composite beams within a rigid floor diaphragm are generally only designed for
gravity loading - since the rigid floor diaphragm deals with any lateral load, distributing it directly to
the vertical stability system. By classifying the beam as gravity only, it will only ever be subjected to
gravity combinations, speeding up the autodesign or check design process (as appropriate) and
reducing the amount of report output.

Columns that are not part of the vertical stability system (braced bays) and thus not being considered
to resist lateral load could be set as gravity only. These columns would only ever be subjected to
gravity combinations, speeding up the autodesign or check design process (as appropriate) and
reducing the amount of report output.

Step 3. Select the below entities and review their Gravity only status.
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Note that the 1st and 2nd floor beams are all ticked hence they will be designed for gravity only
combinations, with the exception of SB 2/B/2-2/C/2 and SB 2/C/2-2/C/3 to the perimeter of the
void and the beams forming the moment frame.

All other entities that are unticked they will be designed for both gravity and lateral combinations.

30.2.2 Autodesign

The Autodesign option specifies how you want the entity to be designed. The option has two settings:

· Unticked - the specified section will be checked during the design process for the section
you have specified.
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· Ticked - sections from the design section order will be considered during the design process
to auto size the entity.

Design Section Order - Specifies the order file from which the designed sections will
be selected. i.e. a design order file comprising UKB sections, RHS sections etc. with
increasing capacity. This order file can be amended so that only the sections you
want to consider are included in the list.

Step 4. Select the below entities and review their Autodesign status.
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All other entities that have the Autodesign option “ticked” and will therefore be
sized based on the designated order file (UKC for columns and UKB for beams).
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30.3 Design Options

TSD combines both the analysis and design into a single process via the Design tab. In the session
you are primarily concerned with the design of steel. You will therefore concentrate on the Analysis
and Design Steel group.

Analysis is still available via the Analyse tab and you will review the analysis results later via the
Review view.

Prior to undertaking a design you need to review the Design Options which control how the design
process will run.

Step 1. Click the Options command in the Design tab.
Step 2. Review the various folders down the left side of the dialog. These are discussed below.

30.3.1 Analysis

The Analysis options on this page allow you to choose whether a first or second order 3D Building
Analysis is performed when any of the Design (Gravity), Design (Static) or Design (RSA) commands
are run. An option is also provided to include sway stability analysis.

The analysis type you wish to run can be selected and will either consider geometric (P-delta) non-
linearity (second order effects) or not - dependent upon the option selected.

What is Geometric (P-delta) Non-linearity?

In first-order analysis the stiffness of the structure is assumed to be constant and unaffected by
changes in the geometry of the structure when it is loaded. The internal forces (and displacements)
are evaluated in relation to the undeformed structure.

This is the standard assumption of linear–elastic first order analysis.
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In the case of first order linear-elastic analysis, the deformations (and internal forces) are
proportional to the applied loads, and as a consequence the principle of superposition of effects can
be used to simplify the analysis.

In second-order analysis, the effective stiffness of the structure is changed by the action of the loads
upon it. The principles of superposition do not apply, as effects of actions interact.

Second-order effects, often called geometric or P-delta effects, are commonly illustrated by
considering the additional displacement, forces and moments which arise from the application of
actions on a deflecting structure.

A second-order analysis considers these geometric (P-delta) second order effects.

First-order (Elastic) Analysis

Runs a linear static analysis. Suitable where geometric (P-delta) secondary effects are negligible and
can be ignored.

Note that if the model contains any material non-linearity such as tension or compression only
elements, non-linear spring supports or non-linear axial or torsional springs then the design will
automatically run the appropriate non-linear analysis – in this case ’First-order non-linear’ in order
to consider material non-linearity.

· First-order (Linear-Elastic) – Geometric non-linearity No, Material non-linearity No.

· First-order (Non-linear) – Geometric non-linearity No, Material non-linearity Yes.

Second-order (P-delta) Analysis – Amp. Forces Method

This is not a true second-order analysis and runs a linear static analysis and applies an amplification
factor to the linear analysis to approximate for geometric (P-delta) secondary effects via an
amplification factor.

Note that if the model contains any material non-linearity such as tension or compression only
elements, non-linear spring supports or non-linear axial or torsional springs then the design will
automatically run the appropriate non-linear analysis – in this case ’First-order non-linear’ in order
to consider material non-linearity.

· First-order (Linear-Elastic) – Geometric non-linearity No, Material non-linearity No.

· First-order (Non-linear) – Geometric non-linearity No, Material non-linearity Yes.

Second-order (P-delta) Analysis

This is a true second-order method and runs a second-order linear analysis which automatically takes
account of geometric (P-delta) secondary effects as part of the analysis.

As with all true second order approaches it will only provide an analysis for a structure that does not
collapse under the design loading. Hence care is required when using this approach to ensure a stable
model.

Note that if the model contains any material non-linearity such as tension or compression only
elements, non-linear spring supports or non-linear axial or torsional springs then the design will
automatically run the appropriate non-linear analysis – in this case Second-order non-linear’ in order
to consider material non-linearity.
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· Second-order (linear) – Geometric non-linearity Yes, Material non-linearity No.

· Second-order (Non-linear) – Geometric non-linearity Yes, Material non-linearity Yes.

Table of Analysis Options and Non-linearity consider

Analysis Type Non-Linearity

Geometric Material

First-order linear (elastic) No No

First-order non-linear No Yes

First-order Vibration No No

Second-order linear Yes No

Second-order non-linear Yes Yes

Second-order buckling Yes No

30.4 Design Steel (Gravity)

Design Steel (Gravity) is  used  for  rapid  design  of  the  majority  of  steel  members  for  gravity
combinations.

The processes can be summarised as follows:

1. A first-order linear analysis is run - excluding pattern loading - to establish a set of design
forces for the steel members. Each steel member with the member property ’Gravity only -
ticked’ is then either checked, or designed - according to its Autodesign setting - for Gravity
combinations only.

2. 'Other' steel members with the member property ’Gravity only – unticked’ and set to auto-
design are designed for Gravity combinations, to give them a reasonable start size prior to
consideration of the Lateral combinations.

3. On completion of the gravity sizing process all steel members follow the Design Options –
Autodesign rules and are either set to check-design mode (Reset Autodesign...Always) or
retain the auto design setting (Reset Autodesign...Never or When check status is at Worst)
dependent upon the option set.

30.4.1 How do I run Design Steel (Gravity)?

· First, check the individual member Autodesign property is correctly set for all members:

o Autodesign ‘ON’ - new section sizes will be designed

o Autodesign ‘OFF’ - existing section sizes will be checked

· Next, review the Design options and adjust if required:

· Click Design Steel (Gravity) to undertake the gravity design for the steel elements.

At the end of the analysis-design process, the active view switches to a Review View
and the ribbon switches from Design to Review - ready for reviewing the design
graphically.

Step 1. Click the Design Steel (Gravity) command.
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30.5 Check the Status

Always review the Status tab of the Project Workspace prior to accepting results in the Review view
as this will indicate if you have any issues that need addressing.

Step 1. Review the Status tab for any issues.

If there are no issues reported - as you have here, then you can proceed. Otherwise you would need
to investigate the issues raised here prior to looking at the design results.

30.6 Check the Loading Summary

Before preceding you should check that the total applied loads on the structure equal the total
reactions.

Step 1. Review the Loadcases and Combinations in the Loading tree to ensure there is no lost load.
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30.7 Review View

The Review View displays a colour coded version of the model so that the design status and various
other parameters can be graphically interrogated and/or modified.

30.7.1 Design – Status

The design status shows graphically the steel elements design status.

Step 1. Review your results after the Steel Design (Gravity) process – i.e. only carrying out a design
on active combinations classed as gravity.

You can see the following;
Two columns set with Autodesign unticked i.e. check design only - Fail.
Two roof braces set with Autodesign unticked i.e. check design only - Fail.

30.7.2 Design – Ratio

The worst design utilisations ratio is displayed in colour coded form.
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30.7.3 Show\Alter State – Auto\Check Design

The Auto\Check Design command provides a means to graphically assess and modify the Autodesign
setting for all members in the model.

The two internal columns and roof braces were failing the gravity design previously so we will assign
them the Autodesign status to re-size them.

Step 1. Use the Auto\Check Design view on the Review tab to set the two failing columns and roof
braces to Autodesign.
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30.7.4 Show\Alter State – Diaphragm On\Off

The Diaphragm On\Off command provides a means to graphically assess and modify those slabs in
the model that are constrained by diaphragms.

Each slab is colour coded to indicate it is Included or Excluded in the diaphragm.

· Clicking on an individual slab toggles its state between included and excluded.

· Dragging a box from right to left toggles the state for all slabs that are either enclosed by
the box, or are cut by the box perimeter.

· Depressing the SHIFT key and dragging a line toggles the state for all slabs that cross the
line.

30.7.5 Show\Alter State – Restrained\Unrestrained

The Restrained\Unrestrained command provides a means to graphically assess and modify the
restraint settings for all members in the model.

Each  member  is colour coded to indicate its restraints setting (N/A, Unrestrained, Partially
Restrained, and Fully Restrained).

· Clicking on an individual member toggles its restraint setting between the types applicable
to the member.

· Dragging  a  box  from  left  to  right toggles the restraint setting for all members totally
enclosed by the box.

· Dragging a box from right to left toggles the restraint setting for all members that are either
enclosed by the box, or cut by the box perimeter.

· Depressing the SHIFT key and dragging a line toggles the restraint setting for all members
that cross the line.
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30.7.6 Show\Alter State – Fixed\Pinned

The Fixed\Pinned command provides a means to graphically assess and modify the end fixity for all
members in the model.

Each member is colour coded to indicate its end fixity setting (N/A, Pinned, Fixed, Moment, Mixed,
and Cantilever).

· Clicking on an individual member toggles its end fixity settings between the types that are
valid for the member.

· Dragging  a  box  from  left  to  right toggles  the  end  fixity  settings  for  all  members  totally
enclosed by the box.

· Dragging a box from right to left toggles the end fixity settings for all members that are
either enclosed by the box, or cut by the box perimeter.

· Depressing the SHIFT key and dragging a line toggles the end fixity setting for all members
that cross the line.

Where the end fixity is shown as ‘Mixed’ this indicates that the fixity at end 1 differs
from that at end 2. ‘Mixed’ end fixity can only be specified by editing the member
Properties directly.

In  this  model  some columns are  not  intended to  resist  any lateral  load.  Now we will  change the
releases of the column stacks from fixed to pinned.

Step 1. Run the Fixed/Pinned command to quickly toggle each stack of the 6 columns identified in
the screenshot below from Fixed to Pinned.
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30.7.7 Show\Alter State – Steel

Steel element characteristics can be changed graphically such as Section, Grade etc.

The member clicked on has to be of the same type (beam, column, or brace) as the
source member.

Now we will rationalise the primary beams on the 1st and 2nd floor level so that they are all a UKB
457x152x52 section.

Step 1. Run the Steel command from the Review tab - Show\Alter State group.

Step 2. In the Properties window, select the parameter to copy (Section, Grade or Both).

Step 3. Select Section – UKB 457x152x52 (1)

Step 4. Click on the member (2) (as in screenshot) to which the selected section to be copied to.

Step 5. Press Esc key to end the command.
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Step 6. Select on Member (1) (as in screenshot) containing the steel to be copied.

Step 7. Click on the members (2), (3) & (4) to which you want to apply the steel.

The section will then be updated on each member you click on.

30.7.8 Show\Alter State – Copy Properties

The Copy Properties command provides a means to graphically copy a specified element parameter
(e.g. web openings, connectors or transverse reinforcement) from a source member to other valid
target members.

To copy a specific property from one member to another:

1. In the Properties window, select the parameter (1) of the member you want to be copied
(e.g. web openings, connectors or transverse reinforcement).

2. Click on the source member that contains the property to be copied (2).
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The colour coding should update accordingly:

· Source - this colour identifies the member that was clicked on. (If this is incorrect, press
Esc then reselect.)

· Same as Source - this colour identifies those members in which the selected parameter
already matches the Source.

· Valid Target -  this colour identifies those members to which it is possible to copy the
selected parameter.

· NA - this colour identifies those members to which it is not possible to copy the selected
parameter.

Either click on an individual target member, or box around a series of target members to copy the
selected parameter to them.

Now we will rationalise the secondary beams on the 1st and 2nd floor level so all internal secondary
beams are a UKB 254x146x31 section.

Step 1. Run the Copy Properties command from the Review tab - Show\Alter State group.

Step 2. In the Properties window, select the parameter of the member you want to copy (e.g. web
openings, connectors or transverse reinforcement, steel or steel grade).

Step 3. Select Steel Section (1).

Step 4. Click on the source member (as screenshot below) that contains the property to be copied
(2).

Other members that already have this section are coloured ’same as source’ to aid
identification.

Step 5. Either click on an individual target member, or box around a series of target members to
copy the selected parameter to them. (See screenshot below).

The section will then be updated on each member you click on.



30 Analysis and Design of Steel Structure 233 (257)

TSD 2016 Manual Tekla Structural Designer
© Trimble Solutions Corporation | April 12, 2016 Fundamental Training

30.8 Interrogate and Review Individual Members

30.8.1 Right Click Context Menu – Edit Member

Displays the Edit Element Properties dialog for the currently highlighted element to allow you to
edit the properties for the member.

§ You can only edit a single entity in this manner.
§ To edit multiple entities it must be undertaken via the Properties window for

the current selection.

30.8.2 Right Click Context Menu – Open Load Analysis View

Opens a Loading Analysis View for the currently highlighted member.

Refer to the screenshot below to review the analysis results of interest.
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30.8.3 Right Click Context Menu – Open Member View

Opens a Member View containing the currently highlighted member and any members connecting
to the highlighted one.

30.8.4 Right Click Context Menu – Show Member Loading

The Member Loading dialog tabulates all the loads applied to the currently highlighted member.
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30.8.5 Right Click Context Menu – Check Member

Carries out a check design of the highlighted member and displays the design calculations for you to
interrogate.

30.8.6 Right Click Context Menu – Design Member

Carries  out  a design of the highlighted member and displays the design calculations for you to
interrogate.

30.8.7 Right Click Context Menu – Report for Member

Opens a Report View for the currently highlighted member.
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30.9 How to Check Member/ Design Member/ Edit…

You can use Check Member to review the individual design results for a member.

· You could then Edit Member to make appropriate changes and Check Member again to
see if the Edits were sufficient to satisfy the design requirements.

· Or you could Design Member to automatically design (size) the member.

A couple of scenarios are detailed below to help explain how the Check, Design and Edit commands
could be utilised.

30.9.1 Scenario 1 – Check Member/ Design Member

In your model you could right click an entity with say a Fail and review the Check Member results.

You could then Design Member to re-design the member (i.e. increase section size etc.) to satisfy
the previous fail status.

Step 1. Right click beam SB 1/A/5-1/B/5 and Check Member to review the results.
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The beam current size is UKB 457x191x67 and has a fail related to Buckling Lateral Torsional.

Step 2. Click Close to exit the Check Member dialog.
Step 3. Right click same beam and Design Member to review the design results.

The beam now has been resized to UKB 457x191x74 to satisfy the Buckling Lateral Torsional.

The analysis results are no longer up to date as the increased section will affect the
analysis. The design is based on the previous analysis results.

30.9.2 Scenario 2 – Check Member/ Edit Member/ Check Member

Alternatively, you could also use Edit Member to alter some properties (i.e. increase the section size)
to resolve the warning/fail issue.

Finally you could Check Member to check that the edit resolves the design warning based on the
original analysis results.

Step 1. Right click beam SB 1/A/2-1/B/2 and Check Member to review the results.
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The beam current size is UKB 533x210x82 and has a fail related to Buckling Lateral Torsional.

Step 2. Double left clicking on same beam.
Step 3. In the Properties window, increase the section size to UKB 533x210x92.

Step 4. Right click same beam and Check Member to review the results.

The beam now passed the design checks with your specified section size.
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30.10 Design Steel (Static)

The Design Steel (Static) processes can be summarised as follows:

1. A first-order linear analysis of all unfactored loadcases is carried out to establish
Serviceability Limit State requirements such as deflections.

2. EHF's are determined for every active combination in which they have been included.

3. Having established the EHF's, their contributions to frame deflections are determined using
a first-order linear analysis. αcr values are also established.

4. The  analysis  type  that  you  have  set  in  Design  Options  is  then  performed  for  all  active
combinations to establish design forces.

5. All steel members set to auto-design mode are designed for the appropriate design
requirements. Gravity members are designed for gravity combinations, lateral members are
designed for all combinations. Only active combinations are checked. If section sizes are
changed the analysis-design cycle is repeated.

6. All steel members set to check mode are checked for the appropriate design requirements.
Gravity members are checked for gravity combinations, lateral members are checked for all
combinations. Only active combinations are checked.

7. At the end of the process, all Autodesign settings follow the Design Options – Autodesign
rules and are either set to check-design mode (Reset Autodesign...Always) or retain the
Autodesign setting (Reset Autodesign...Never or When check status is at Worst) dependent
upon the option set.

30.10.1 How to run Design Steel (Static)

· First, check the individual member Autodesign property is correctly set for all members:

o Autodesign ‘On’ - new section sizes will be designed

o Autodesign ‘Off’ - existing section sizes will be checked

· Next, review the Design options and adjust if required:

· Click Design Steel (Static).

o Gravity members are designed/checked dependent upon the Autodesign setting for all
active gravity combinations only.

o Lateral members are designed/checked dependent upon the Autodesign setting for all
active combinations.

At the end of the analysis-design process, the active view switches to a Review View
and the ribbon switches from Design to Review - ready for reviewing the design
graphically.

Step 1. Run Steel Design (Static) and review the Design Status on the Review View.
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The lateral combinations are generating horizontal forces which are being distributed into the braced
bays and moment frames. These inevitably increase the design force to be resisted by the existing
sections. In the case of the columns these were originally sized to satisfy just the gravity combination.

30.10.2 Using the Review View again

Step 1. Reset eight columns which attached to braced or moment resisting frames back to
Autodesign ’On’ using the Auto\Check Design command as the screenshot below.

· With Autodesign ‘On’ - new section sizes will be designed.

· Since these entities are not classified as ’Gravity only’ they will be sized for all the active
combinations when a Steel Design (Static) is undertaken again.
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· If a Steel Design (Gravity) was performed instead, they would only be sized for the active
gravity combinations only.

Step 2. Reset any failing brace members to Autodesign ‘On’.
Step 3. Reset any failing moment beam members to Autodesign ‘On’
Step 4. Re-run the Steel Design (Static) command to resize the failing members.

All the entities should now be passing.

Step 5. Save the model using File > Save As and name the model Design_Runthrough.tsmd.

30.11 Using Result View to Investigate Solver Warnings

30.11.1 Project Workspace – Status

After running the design, you should always investigate any issues reported in the Project
Workspace- Status, before reviewing design results in the Review View. The Results View is intended
to help you investigate these instabilities.

To demonstrate this, open a model that has instabilities and use the Results View to assess the forces
and deflections of the model to determine the causes of the instabilities.

Step 1. Open the model file 2_Design_Start_Instabilities.tsmd.
Step 2. Review the loadcases and combinations that exist in the model.
Step 3. Run a Design Steel (Gravity).
Step 4. Review the Project Workspace – Status for any issues.

Click the ’+’ or ’-’ to expand/contract the branch of the Status tree in order to drill
into the item of interest.
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· A  ’?’ symbol exists against Validation – Analysis.
This indicates that only a First-order linear analysis has
been undertaken. This is the analysis type requested
under the Design options.

· A  ’Warning’ symbol exists against the Solver branch
indicating that 150 nodes exceed a deflection limit of
1000mm for load case Wind 0, -Cpi, -Cpe and to check
the structure is stable.

· An ’i’ (information) symbol exists against the Solver –
Model folder to indicate that the lateral combinations
have not yet been considered.

· A ’ü’ indicates that there are no issues with the item.

You can double left click a Solver item in the Status tree and the Solver view will open showing the
underlying analysis model.

Step 5. Double left click the Solver warning to open a Solver view and highlight the node with the
maximum deflection.

Step 6. Run a Design Steel (Static).
Step 7. Review the Project Workspace – Status for any additional issues.

In addition to the Wind 0 load case, all lateral combinations that produce a deflection greater than
1000mm are also being identified.
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To investigate this further you need to review the deflected shape of the model. This is achieved
using the Results View.

30.11.2 The Result View

Step 1. Click on the Results View icon on the status bar to switch to the Results View mode. The
Results tab will appear.

You can also right click the active view tab and select the Results View from the
context menu.

Step 2. Select the loadcase or combination you wish to view results for (1). See screenshot below.
Step 3. Use the Results tab to set the analysis type (2), Item(s) to display (3) and text to overlay on

the diagram (4).
Step 4. Use the sliders to scale the display (5).
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Step 5. Investigate the model displacement for loadcase 6 ‘Wind 0, Cpi -0.3, -Cpe’.

The model has deflected greater than 1000mm in the X direction indicating a mechanism - so we
need to review the bracing.

The 1000mm threshold is an order of displacement that TSD considers appropriate
to indicate the possibility of a mechanism. It is not an indication that the structure
satisfies deflection limits imposed by the Code of Practise in use.

Clearly, there is no steel bracing in the X direction so what form of bracing do we have to use to
stabilise the model? Are there moment resisting frames in the model? If so, are they correctly
defined?

Step 6. Switch back to the Review View.

Step 7. Review the Fixed\Pinned command. This indicates that the 1st and 2nd floor beams are all
pinned, hence they are not acting as moment resisting frames.

Step 8. Adjust the beams identified below to Moment by clicking on each beam the required
number of times to toggle between the valid states.
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Step 9. Re-run the Design Steel (Static).

The Warnings in the Project Workspace – Status have been resolved and you can now proceed with
the design.
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30.12 Tabular Data

Two different types of tabular data can be reported.

· Design data such as sway, design summary, material listing section resistances etc.

· Analysis data such as nodes, elements, nodal forces, element forces etc.

30.12.1 Design Tabular Data

Design tabular data can be accessed from the Review tab > Tabular Data command.

Step 1. On the ribbon set the View type (1), Material type (2), Characteristic (3) etc. and apply a
Filter (4) if required.
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30.12.2 Analysis Tabular Data

Analysis tabular data can be accessed from the Analyse tab > Tabular Data command.

Step 1. Set the Result type (1) and the View type (2) to display.
Step 2. To request for force or displacements, select a loadcase or combination from the load drop

list (3).
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31 Foundation Design

31.1 Introduction

You can model and design Pad & Strip Footing in TSD model.

Pad & Strip Footing can be auto designed based on size,
depth and bottom reinforcement.

You are also able to group the design of bases which can
be set in Design Options.

31.2 Using Cutting Planes

Step 1. Open the model file TSD Concrete Design Model - Foundation.tsmd
Step 2. Run Design (Static).
Step 3. Go to Edit tab and select on Cutting Planes command.

(It is used to reduce the active 3D view to show only the lower floor level)
Step 4. Click on the top plane (1) – it will turn into blue color.
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Step 5. Click on the blue arrow (2) to move the top plane.
Step 6. Move the plane to above first floor level (3).

Step 7.  Press Esc key or double right mouse click to stop the command.

We are going to use this view to insert the pad footing under the columns.
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31.3 Model of Pad Footing

You can model the pad footing supporting columns in the 3D view or Base 2D view.

Step 1. Set to Structure 3D view
Step 2. Go to Foundation tab and click on Pad Base Column button.

Step 3. Review the Properties window – tick on Auto-design depth, size & reinforcement and set
Bearing Capacity to be 200kN/m2.

Step 4. Drag a window (from left to right) to encompass the whole model to insert pad footing on
all the columns.

31.4 Design of Pad Footing

Step 1. Go to Foundation tab and click on Design Isolated button.
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31.4.1 Rationalise bases

The pad footings are designed with different sizes, to rationalise them we can use property sets to
group similar size bases from the first design.

Step 2. Set to St. Base (Base) 2D view.

Use Property Set to group the bases accordingly to the first designed size – see below 4 required
groups to create.

Step 3. Select on the pad footing at gridline 3/A (biggest size of the group), right mouse click – on
the context menu, select Create property set….

Step 4. Name the property set as Footing 1.

Step 5. Select the remaining 5 pad footings to be applied with the same property set ‘Footing 1’
using “Apply” button in the Properties window.
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You can also select on a pad footing, use Apply Property Set… from the right click
context menu. This only applies to one pad footing at a time.

Step 6. Repeat the same process to create 3 more property sets with pad footing at gridline 1/D,
1/C & 2/C naming them as Footing 2, Footing 3 & Footing 4 respectively.

The footing to be used to create property size has to be the biggest size (i.e. most
critical one) to ensure those footings applied with its same property set are able to
pass when re-designed them.

You can check via Home tab > Manage Property Sets for all the property sets created.

Step 7. Use Apply Property Set… to apply each property set created to the remaining pad footings.
Step 8. Go to Design tab and click on Options button  –  in Design Groups option,  tick  ‘Isolated

Foundations’ to set to grouping design.
Step 9. Update the analysis result by running 1st Order Linear Analysis again.
Step 10. Go to Foundation tab and click on Design Isolated button to run design for the newly

grouped pad footings.
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31.5 Model of Strip Footing

You can model the strip footing supporting walls in 3D view or Base 2D view.

Step 1. Set to St. Base (Base) 2D view.
Step 2. Go to Foundation tab and click on Strip Base Wall button.

In the earlier exercise, we have learnt how to set auto design for pad footing where TSD proposed a
suitable footing size. In this exercise, we are going to manually define the strip footing size and then
get TSD to design for the required reinforcement only.

Step 3. In the Properties window – Untick on Auto-design depth & size, tick on Auto-design
reinforcement and set Bearing Capacity to be 300kN/m2.

Step 4. Set Width to be 2600mm, Extension to be 1300mm and Depth to be 550mm.
Step 5. Click on the wall to create strip footing.
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Step 6. Go to Foundation tab and click on Design Isolated button.

Now all the footings have been successfully designed and next we can look at how to get the
foundation drawings.

31.6 Foundation Drawings

Step 1. Go to Draw tab and click on Foundation Layout button.
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31.7 Foundation Design Report

Step 1. Go to Report tab and click on Model Report…
Step 2. In the Report Contents page, click on Add button – Name as Pad Bases Design.
Step 3. From the Chapters and Options column, select on Concrete > Pad Base Design and drag it

into Report Structure column.

Step 4. Click OK to exit.
Step 5. In the Select list, choose Pad Bases Design and then click on Show Report.
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32 Changing the Design Code (For Information only)

32.1 Introduction

TSD allows you to choose from a range of international design codes of practice.

Each new project will initially adopt the codes that have been specified in Settings from the Home
tab when create a new blank file, however it is also possible to change codes in mid project.

32.2 Head Code

A head code is selected which configures the choices available for the following codes:

Action Codes Resistance Codes
General Loading Steel Design
Wind Loading Concrete Design
Snow Loading Composite Design
Seismic Loading Timber Design
Combinations Masonry Design

Foundation Design
Seismic Design and Detailing

32.3 How to Configure the Default Design Codes to be applied to New Projects?

Step 1. Click Settings on the Home tab.
Step 2. Select a suitable settings set from the drop list and make it Active.
Step 3. Use the Design Codes page of the Settings dialog to choose the Codes required.

Having set the codes as required, TSD will retain these as the default codes to apply for each new
project until you decide to amend them.

To start a new project with the chosen design codes:

Step 4. Click New on the Home tab.

32.4 How to Change Design Codes in an Existing Project?

Step 1. Click Model Settings from the Home tab.
Step 2. In the Design Codes page of the dialog choose the Codes required.

32.5 Model Changes

If you change design codes in mid project, you need to be aware of the following model changes:

· Any existing wind load data will be lost – you will therefore need to recreate them.
· Any existing load combinations will be lost - you will therefore need to recreate them.
· Steel material properties will be amended.
· Rebar material properties will be amended.
· Concrete material properties will be amended.
· Composite stud data is lost – you will therefore need to re-assign the data.
· Effective lengths will be set to 1.0L
· All existing design checks will be deleted and a re-design will be necessary.


